LAVA Command-line Tool

proxy setting not respected by lava-tool

Reported by Benjamin Gaignard on 2011-11-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
LAVA Tool
Critical
Michael Hudson-Doyle

Bug Description

The proxy setting (like http_proxy environment variable) aren't respected/used by lava-tool.

A consequence is that lava-tool auth-add can't be performed below a proxy.

Output debug trace after lava-tool auth-add:

Traceback (most recent call last):
  File "/usr/bin/lava-tool", line 9, in <module>
    load_entry_point('lava-tool==0.2', 'console_scripts', 'lava-tool')()
  File "/usr/lib/pymodules/python2.6/lava_tool/dispatcher.py", line 85, in main
    run_with_dispatcher_class(LavaDispatcher)
  File "/usr/lib/pymodules/python2.6/lava_tool/dispatcher.py", line 81, in run_with_dispatcher_class
    raise SystemExit(cls().dispatch())
  File "/usr/lib/pymodules/python2.6/lava_tool/dispatcher.py", line 74, in dispatch
    return command.invoke()
  File "/usr/lib/pymodules/python2.6/lava_tool/commands/auth.py", line 110, in invoke
    token_user = sp.system.whoami()
  File "/usr/lib/python2.6/xmlrpclib.py", line 1199, in __call__
    return self.__send(self.__name, args)
  File "/usr/lib/python2.6/xmlrpclib.py", line 1489, in __request
    verbose=self.__verbose
  File "/usr/lib/python2.6/xmlrpclib.py", line 1235, in request
    self.send_content(h, request_body)
  File "/usr/lib/python2.6/xmlrpclib.py", line 1349, in send_content
    connection.endheaders()
  File "/usr/lib/python2.6/httplib.py", line 908, in endheaders
    self._send_output()
  File "/usr/lib/python2.6/httplib.py", line 780, in _send_output
    self.send(msg)
  File "/usr/lib/python2.6/httplib.py", line 739, in send
    self.connect()
  File "/usr/lib/python2.6/httplib.py", line 720, in connect
    self.timeout)
  File "/usr/lib/python2.6/socket.py", line 561, in create_connection
    raise error, msg
socket.error: [Errno 110] Connection timed out

Related branches

Changed in lava-tool:
importance: Undecided → High
status: New → Confirmed

The issue seems to be located in xmlrpclib.Transport class.
We need to take care of the proxy setting when we establish the http connection

Alexander Sack (asac) wrote :

that seems to be an awful situation for many of our proxy locked-in assignees. atm its still ok, but once more folks pick up lava and want to use it to get one time verification of stuff this becomes a real issue.

Zygmunt Krynicki (zkrynicki) wrote :

I'll get around to fix this pretty soon. I was about to improve a few lava-tool parts that have proven to be bad for end users based on the feedback so far. One of the main issues is all of the URL handling and associated error messages (they don't help). I will look at transport proxy at the same time.

Paul Larson (pwlars) wrote :

You said you had some patches for this when we talked last, is it landing in time for 2011.12?

Changed in lava-tool:
assignee: nobody → Zygmunt Krynicki (zkrynicki)
Zygmunt Krynicki (zkrynicki) wrote :

Not for this cycle, I assumed it will end "later" as usual so I think this will be postponed to 2012.01

Changed in lava-tool:
importance: High → Critical
Changed in lava-tool:
milestone: none → 2012.06
assignee: Zygmunt Krynicki (zkrynicki) → nobody
Michael Hudson-Doyle (mwhudson) wrote :

Testing of the attached branch would be massively appreciated!

Changed in lava-tool:
assignee: nobody → Michael Hudson-Doyle (mwhudson)
status: Confirmed → In Progress
Changed in lava-tool:
status: In Progress → Fix Committed
Fathi Boudra (fboudra) on 2012-06-29
Changed in lava-tool:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers