lava-test fails to load out-of-tree test after boot to test image

Bug #915915 reported by Andrew Stubbs on 2012-01-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Obsolete LAVA Test
Fix Released
High
Le Chi Thu

Bug Description

I'm trying to run a GCC build test using an out-of-tree json testfile. The test successfully registers with lava-test, and successfully executes the install steps (download and unpack a gcc source tarball), but then fails to run the actual build part of the test.

See line 12934 onward from the serial log here:
  http://validation.linaro.org/lava-server/dashboard/streams/anonymous/ams/bundles/a87f2213ed98034fc675298b1f90e5d93755b92f/219e4eb8-3d3c-11e1-9729-68b599be548c/attachments/36337/

I've attached the test file I'm using.

And, here's the dispatcher json file I'm using.

Le Chi Thu (le-chi-thu) wrote :

Not able to reproduce since the json file contains local ip address (192.168.x.x).

Please use this version of lava-test to print out more detail logs.

https://code.launchpad.net/~le-chi-thu/lava-test/fix-898092

Changed in lava-test:
importance: Undecided → Critical
status: New → Incomplete
importance: Critical → High

Yeah, the test file loads the source files from control.linaro.com.
You can probably pull the file from my home directory.

Andrew
On 13 Jan 2012 12:15, "Le Chi Thu" <email address hidden> wrote:

> Not able to reproduce since the json file contains local ip address
> (192.168.x.x).
>
> Please use this version of lava-test to print out more detail logs.
>
> https://code.launchpad.net/~le-chi-thu/lava-test/fix-898092
>
> ** Changed in: lava-test
> Importance: Undecided => Critical
>
> ** Changed in: lava-test
> Status: New => Incomplete
>
> ** Changed in: lava-test
> Importance: Critical => High
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/915915
>
> Title:
> lava-test fails to load out-of-tree test after boot to test image
>
> Status in LAVA Automated Testing Framework:
> Incomplete
>
> Bug description:
> I'm trying to run a GCC build test using an out-of-tree json testfile.
> The test successfully registers with lava-test, and successfully
> executes the install steps (download and unpack a gcc source tarball),
> but then fails to run the actual build part of the test.
>
> See line 12934 onward from the serial log here:
>
> http://validation.linaro.org/lava-server/dashboard/streams/anonymous/ams/bundles/a87f2213ed98034fc675298b1f90e5d93755b92f/219e4eb8-3d3c-11e1-9729-68b599be548c/attachments/36337/
>
> I've attached the test file I'm using.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/lava-test/+bug/915915/+subscriptions
>

I now have an updated json file (attached) that I've now confirmed runs on my local machine. I still fails on the LAVA panda boards though. I've removed the local ip address from the script (there's still one at the end, but that's after the failure).

The log file is here: http://validation.linaro.org/lava-server/scheduler/job/11960/log_file

The install phase runs fine, but the run phase just doesn't happen - it just says "ERROR: There is no test with the specified ID".

Apologies for the delay.

Le Chi Thu (le-chi-thu) wrote :

The gator test for android works. Here is the result -
http://validation.linaro.org/lava-server/scheduler/job/13375

Changed in lava-test:
assignee: nobody → Le Chi Thu (le-chi-thu)
status: Incomplete → Fix Released

I tried this again. It still fails. The results are here:
http://validation.linaro.org/lava-server/dashboard/permalink/test-run/2d255dd8-6142-11e1-9729-68b599be548c/

Le Chi Thu's theory was that the test image was running out of disk space and this was causing the problems. This test run used a reduced size tarball (I removed all the .svn directories). The untar and subsequent wget commands both appear to succeed, and the install test is marked "Test passed".

It might be that disk space will become an issue during the build phase, but we haven't got there yet.

There are several suspicious message like

   (stk) :line disc installation timed out

 in the boot log, and also

   udevd[854]: worker [864] did not accept message -1 (Connection refused), kill it

looks worrying to me.

I need a resolution to this problem because it is blocking my progress. :(

Thanks

Andrew

Le Chi Thu (le-chi-thu) wrote :

Now the lava-dispatcher and lava-test is updated to handle out of tree properly. Here is the job which verified this.
http://validation.linaro.org/lava-server/scheduler/job/15633

Changed in lava-test:
milestone: none → 2012.03
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers