"working" status bar covers up the menu

Bug #881808 reported by Paul Larson
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
LAVA Server
Fix Released
High
Zygmunt Krynicki

Bug Description

When loading the lava-server main page, the reports on the page cause the "working" status bar to appear at the top of the page while they are loading. Unfortunately that also completely covers up the main menu making it impossible to navigate to other pages.

Revision history for this message
Spring Zhang (qzhang) wrote :

Not just that, if I click one item(like nano+lt-panda) below the 'working' bar after it appears , I can't browse all the result. See the attached picture, the results after item 9 don't display.
I use Firefox 3.6.23.

Revision history for this message
Paul Larson (pwlars) wrote :

spring: that's unrelated. What you are seeing is because you are browsing from validation.linaro.org through an iframe. We'll be shutting that page off and redirecting to /lava-server, probably tomorrow I'm guessing. Until then, I would recommend just going directly to /lava-server.

Zygmunt Krynicki (zyga)
Changed in lava-server:
status: New → In Progress
assignee: nobody → Zygmunt Krynicki (zkrynicki)
importance: Undecided → High
Revision history for this message
Alexander Sack (asac) wrote :

From my dupe bug ...

Some ideas:
 * make the "Loading..." indicator less dominating; improve where it floats, move to bottom area, etc.
 * make an indicator area in the top bar where this type of thing can be displayed.
 * display indicator in the html area where the data will end up. this would also help the user to understand what part of the view will get updated/is incomplete.

Revision history for this message
Paul Larson (pwlars) wrote :

Yep, zyga has a version of this that is much less obrusive. Just a spinner in the top right corner to indicate that things are still loading, and it doesn't block any nav. Should be visible on staging.validation.linaro.org later today.

Fathi Boudra (fboudra)
Changed in lava-server:
milestone: none → 2011.11
Revision history for this message
Zygmunt Krynicki (zyga) wrote :

Released with lava-server 0.7.1, demo on http://staging.validation.linaro.org/

Changed in lava-server:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments