LAVA Scheduler (deprecated)

Submitted time is later than start time

Reported by Yongqin Liu on 2011-09-28
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
LAVA Scheduler (deprecated)
Fix Released
Medium
Michael Hudson-Doyle

Bug Description

on the job display page, the Submitted time is later than start time. like below :
http://validation.linaro.org/lava-server//scheduler/job/2053
    Submitted at:
             Sept. 28, 2011, 4:12 a.m.
    Started at:
             Sept. 28, 2011, 3:12 a.m.
    Finished at:
             Sept. 28, 2011, 4:25 a.m.

Changed in lava-scheduler:
status: New → Confirmed
Fathi Boudra (fboudra) on 2011-10-06
Changed in lava-scheduler:
importance: Undecided → Medium
Yongqin Liu (liuyq0307) wrote :

In my local environment, before I reinstalled lava-dashboard and lava-scheduler, I can reproduce this problem 100%.
But now I can't reproduce it anymore.
And it seems now v-l-o is ok too.

Dave Pigott (dpigott) wrote :

Take a look at http://validation.linaro.org/lava-server/scheduler/job/2447 - A job run this morning. Time submitted is still one hour ahead of time started.

Could this be a summer time correction bug?

Michael Hudson-Doyle (mwhudson) wrote :

Yes, it's a time zone bug :( Probably easy to fix, I just keep avoiding it because I hate timezones so much!

Michael Hudson-Doyle (mwhudson) wrote :

What do you know, this is a bug in Django! Reported as https://code.djangoproject.com/ticket/17062

liuyq's observation that using commit_on_success instead of commit_manually was on the right track after all.

Changed in lava-scheduler:
status: Confirmed → Fix Committed
Michael Hudson-Doyle (mwhudson) wrote :

liuyq pointed out that my fix is only partial. Will look harder tomorrow.

Changed in lava-scheduler:
status: Fix Committed → In Progress
Michael Hudson-Doyle (mwhudson) wrote :

I've pushed a more complete fix.

Changed in lava-scheduler:
status: In Progress → Fix Committed
Fathi Boudra (fboudra) on 2011-10-25
Changed in lava-scheduler:
assignee: nobody → Michael Hudson-Doyle (mwhudson)
milestone: none → 2011.10
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.