LSK: Workload automation failed to run on LAVA "vexpress-tc2-benchmark-01"

Bug #1212946 reported by Naresh Kamboju on 2013-08-16
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
LAVA Scheduler (deprecated)
New
Undecided
Unassigned
Linaro Android
Fix Released
Medium
Unassigned
Linaro Stable Kernel (LSK)
Fix Released
Medium
Unassigned

Bug Description

LAVA daily Dashboard reported LSK failed to run Workload automation ( LSK performance test) on "vexpress-tc2-benchmark-01" target device.

adb connection failed very often on device "vexpress-tc2-benchmark-01" due to this reason Workload automation test did not complete for LSK build 57. Outof 48 tests this test completed only 20 and then reported failed to connect device over adb. On TC2 adb runs over TCP connection.

Error log:
------------
lava_android_test_run is finished with error (Failed to connected to device with command:adb connect 192.168.1.38:5555)

 root@linaro# <LAVA_DISPATCHER>2013-08-15 04:08:24 AM INFO: Execute adb command on host: adb disconnect 192.168.1.38:5555
 <LAVA_DISPATCHER>2013-08-15 04:10:15 AM INFO: Execute adb command on host: adb connect 192.168.1.38:5555
 <LAVA_DISPATCHER>2013-08-15 04:12:05 AM WARNING: [ACTION-E] lava_android_test_install is finished with error (Failed to connected to device with command:adb connect 192.168.1.38:5555).
 <LAVA_DISPATCHER>2013-08-15 04:12:05 AM INFO: [ACTION-B] lava_test_shell is started with {u'testdef_repos': [{u'git-repo': u'git://git.linaro.org/qa/test-definitions.git', u'testdef': u'android/bigLITTLE.yaml'}]}
 <LAVA_DISPATCHER>2013-08-15 04:12:05 AM INFO: attempting to access master filesystem 5:lava

Build 57:
--------------
http://validation.linaro.org/scheduler/job/67129/log_file#L_1044_2
Build 58:
--------------
http://validation.linaro.org/scheduler/job/67312/log_file#L_26_2

LAVA Dashboard:
----------------------------
http://validation.linaro.org/dashboard/image-reports/linaro-android-restricted_vexpress-linaro-lsk

Naresh Kamboju (naresh-kamboju) wrote :

Last week: abd install WA done..and .........adb run 22 pass ..........adb run 26 failed.
today : adb install WA failed .... and everything failed

As per my experience with adb connection
I see frequent adb connection fails ... adb pull, adb push fails... when we use mmc

LAVA should be using USB rootfs.

Dave Pigott (dpigott) wrote :

We need more information - is this still happening?

Dave Pigott (dpigott) wrote :

Lava does use usb rootfs

Changed in lava-scheduler:
status: New → Invalid
Mark Brown (broonie) wrote :

Dave, this is still happening for LSK. As far as I can tell this is a LAVA thing, at the very least if there's something broken in the thing being tested LAVA ought to be providing more diagnostics about why the test failed to run.

Please e-mail me or ping me on IRC if there's updates, I've had to killfile all the Launchpad bugmail due to the amount of spam I was getting from subscribed group :/

vishal (vishalbhoj) wrote :

This looks like a LAVA issue itself. lava-android-test running on the dispatcher is not able to clone the git repository:
ssh://linaro-private.git.linaro.org/srv/linaro-private.git.linaro.org/workload-automation.git

Did any of the keys on the server change ?

Mark Brown (broonie) on 2014-01-09
Changed in lava-scheduler:
status: Invalid → New
Dave Pigott (dpigott) wrote :

Can someone give me a link to a recently failed job?

vishal (vishalbhoj) wrote :

davepigott, the job that is failing is https://validation.linaro.org/scheduler/job/93127/log_file . The failure is not during git clone but after that it tries to download an mp3 file :
http://archive.org/download/PachelbelsCanoninD/Canon_in_D_Piano.mp3 and that is when it is failing .

The same python code works locally well

Naresh Kamboju (naresh-kamboju) wrote :

According to the comment #7,
The problem is with proxy setting. Now the proxy settings have been removed.

vishal's patch can be found at:
https://linaro-private.git.linaro.org/gitweb?p=workload-automation.git;a=commit;h=703af65af5940ab36de5f01dbfc2c76f3d1a1d7b

Waiting for the next android build to run on LAVA "vexpress-tc2-benchmark-01".

The following LAVA job running on "vexpress-tc2-benchmark-01" is successfully running workload automation test and getting valid results.

 - https://validation.linaro.org/scheduler/job/95658/log_file#L_53_1085

Changed in linaro-android:
status: New → Fix Released
Changed in linaro-stable-kernel:
status: New → Fix Released
Changed in linaro-android:
importance: Undecided → Medium
Changed in linaro-stable-kernel:
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers