unable to create working master image for pandaboard

Bug #1182214 reported by Milosz Wasilewski on 2013-05-20
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
LAVA master image scripts
High
Dave Pigott

Bug Description

Environment
pandaboard 4430 connected to wired network with DHCP server and Internet access
lava-master-image-scripts rev 75

Steps to reproduce:
1. run ./lava-create-master panda
2. dd the panda-master.img to the SD card
3. plug SD card to pandaboard and power the board
4.
 a) wait for the first boot failure message (happens with linaro releases 13.03 and 13.04)
 b) wait for the first boot to complete and reboot the board (happens with 12.12 and 13.01)

Expected result:
The board boots

Actual result
4 a)
first boot script fails because mismatch in the machine name. The name that comes from the /proc/cpuinfo is:
Hardware : Generic OMAP4 (Flattened Device Tree)
Such name is not present in flash-kernel database, so the initramfs-tools configuration fails (attaching log). After changing the name and manual package reconfiguration the output is similar to the older hwpacks - board doesn't boot.

4 b)
Board doesn't boot. The last message on the serial console is:
Starting kernel ...

Uncompressing Linux... done, booting the kernel.

Changed in lava-master-image-scripts:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Matthew Hart (matthew-hart)
Fathi Boudra (fboudra) wrote :

After updating flash-kernel database, it works for me (assuming initrd is properly generated before rebooting, using apt-get -f install for example). I've updated the package and should be available in ~1h (the build is scheduled in 25min).

Changed in lava-master-image-scripts:
assignee: Matthew Hart (matthew-hart) → Fathi Boudra (fboudra)
milestone: none → 2013.05
status: Confirmed → Fix Committed
Milosz Wasilewski (mwasilew) wrote :

Looks like updating flash-kernel database solves the problem :)

Milosz Wasilewski (mwasilew) wrote :

I repeated the whole setup from scratch using 13.03 hwpack for pandaboard. I still fail to create working image.
1. the initial image conains old version of flash-kernel (I guess this will be fixed with coming release)
2. after updating the flash-kernel package and running /lib/lava/lava-master-init the kernel is not booting any more :(

Fathi Boudra (fboudra) wrote :

According to comments#4 reopen and re-target to next cycle.

Changed in lava-master-image-scripts:
status: Fix Committed → In Progress
milestone: 2013.05 → 2013.06
Fathi Boudra (fboudra) on 2013-06-28
Changed in lava-master-image-scripts:
milestone: 2013.06 → 2013.07
Fathi Boudra (fboudra) on 2013-07-27
Changed in lava-master-image-scripts:
milestone: 2013.07 → 2013.08
Changed in lava-master-image-scripts:
assignee: Fathi Boudra (fboudra) → Dave Pigott (dpigott)
Dave Pigott (dpigott) on 2013-08-22
Changed in lava-master-image-scripts:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers