timeout in image deployment

Bug #881789 reported by Paul Larson
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
LAVA Validation Lab
Fix Released
High
Dave Pigott

Bug Description

Image deployment is timing out for some images, mainly large ones such as ubuntu-desktop

http://validation.linaro.org/lava-server/scheduler/job/2944 has an example of this. I mostly seem to be seeing this in oneiric images it seems.

Fathi Boudra (fboudra)
tags: added: lava-investigation
Revision history for this message
Alexandros Frantzis (afrantzis) wrote :

This is still a problem, at least on pandaboards. The daily Graphics WG test job, which uses an ubuntu-desktop rootfs, routinely times out (e.g. http://validation.linaro.org/lava-server/scheduler/job/5787).

Changed in lava-lab:
status: New → Confirmed
Revision history for this message
Paul Larson (pwlars) wrote :

Fix for this is in progress, and involves replacing slow SD cards in the lab with faster ones. 4 Pandas have been fixed, and more SD cards are due to arrive ASAP

Changed in lava-lab:
importance: Undecided → High
assignee: nobody → Dave Pigott (dpigott)
status: Confirmed → In Progress
milestone: none → 2012.01
Revision history for this message
Alexander Sack (asac) wrote :

shouldnt this be catched by our health check jobs and b oards that cannot deal with ubuntu-desktop stable be taken offline until resolution?

Revision history for this message
Alexander Sack (asac) wrote :

seeing that we use nano for health, I wonder if we should test desktop to catch such issues...

Revision history for this message
Dave Pigott (dpigott) wrote :

Update status:

Pandas upgraded so far:

02, 03, 04, 05, 06, 07, 08, 11, 12, 13, 15, 21, 23, 24

This leaves 10 with the older sd cards. I'm awaiting the final batch to be delivered. Should I take the 10 slower pandas offline until the new sd cards arrive?

Revision history for this message
Paul Larson (pwlars) wrote :

What's the expected delay before we have it? If they are going to arrive quickly, I'd say just leave it as it is. If it's going to be a while though, we should go ahead and offline them for now, and move the health check jobs to a subdir so they don't get run every day.

Revision history for this message
Dave Pigott (dpigott) wrote :

OK. All but 16 and 18 updated because I'm still waiting for more sd cards. I'm putting 16 and 18 offline until they're upgraded.

Revision history for this message
Dave Pigott (dpigott) wrote :

All now up to spec

Changed in lava-lab:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers