Switch vexpress boards from uImage/uInitd to zImage/initrd

Bug #1122088 reported by vishal
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
LAVA Validation Lab
Invalid
Medium
Antonio Terceiro

Bug Description

Android builds for vexpress now produce zImage and Initrd instead of uImage and uInitrd.

Revision history for this message
Ryan Harkin (ryanharkin) wrote :

The UEFI config for booting Android on all vexpress boards will need to be updated to boot "zImage" and "initrd" due to this change in IKS images.

The MP builds are building both uImage and zImage and uInitrd and initrd into the boot partition, so they will also work with this change.

Revision history for this message
Ryan Harkin (ryanharkin) wrote :

Tixy is in the process of updating the config for all the vexpress Android builds to remove many of the hacks other teams have applied. It might be worth checking with him and me before making the change in LAVA.

affects: lava-dispatcher → lava-lab
Changed in lava-lab:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Antonio Terceiro (terceiro)
milestone: none → 2013.02
Revision history for this message
Antonio Terceiro (terceiro) wrote :

Hi, I am looking into this. I will first test the change in vexpress-tc2-02, which is already sidelined for other work, but for this I need a stable image that has zImage/initrd to use as health check image.

Changed in lava-lab:
status: Confirmed → In Progress
Revision history for this message
Antonio Terceiro (terceiro) wrote :

note to self - a "backup" of how the config should look like:

[1] LAVA Master Image
        - VenHw(09831032-6FA3-4484-AF4F-0A000A8D3A82)/HD(1,MBR,0x00000000,0x2000,0x1A000)/zImage.iks
        - Initrd: VenHw(09831032-6FA3-4484-AF4F-0A000A8D3A82)/HD(1,MBR,0x00000000,0x2000,0x1A000)/uInitrd
        - Arguments: console=ttyAMA0,38400n8 root=/dev/mmcblk0p2 rootwait ro mem=1024M
        - FDT: VenHw(09831032-6FA3-4484-AF4F-0A000A8D3A82)/HD(1,MBR,0x00000000,0x2000,0x1A000)/tc2_dtb.bin
        - LoaderType: Linux kernel with Local FDT
[2] LAVA Ubuntu Test Image
        - VenHw(09831032-6FA3-4484-AF4F-0A000A8D3A82)/HD(3,MBR,0x00000000,0x200000,0x20000)/uImage
        - Initrd: VenHw(09831032-6FA3-4484-AF4F-0A000A8D3A82)/HD(3,MBR,0x00000000,0x200000,0x20000)/uInitrd
        - Arguments: console=ttyAMA0,38400n8 root=/dev/mmcblk0p5 rootwait ro mem=1024M
        - FDT: VenHw(09831032-6FA3-4484-AF4F-0A000A8D3A82)/HD(3,MBR,0x00000000,0x200000,0x20000)/v2p-ca15-tc2.dtb
        - LoaderType: Linux kernel with Local FDT
[3] LAVA Android Test Image
        - VenHw(09831032-6FA3-4484-AF4F-0A000A8D3A82)/HD(3,MBR,0x00000000,0x200000,0x20000)/zImage
        - Initrd: VenHw(09831032-6FA3-4484-AF4F-0A000A8D3A82)/HD(3,MBR,0x00000000,0x200000,0x20000)/initrd
        - Arguments: console=tty0 console=ttyAMA0,38400n8 rootwait ro init=/init androidboot.console=ttyAMA0
        - FDT: VenHw(09831032-6FA3-4484-AF4F-0A000A8D3A82)/HD(3,MBR,0x00000000,0x200000,0x20000)/v2p-ca15-tc2.dtb
        - LoaderType: Linux kernel with Local FDT
-----------------------
Global FDT Config
        - VenHw(1F15DA3C-37FF-4070-B471-BB4AF12A724A)/MemoryMapped(0x0,0xE800000,0xE803000)
-----------------------

Revision history for this message
Antonio Terceiro (terceiro) wrote :
Revision history for this message
Antonio Terceiro (terceiro) wrote :

hey, I am marking this bug as invalid as the latest iks jobs have uImage/uInitrd again, and our health job for vexpress-tc2 only has uImage/uInitrd.

Changed in lava-lab:
status: In Progress → Invalid
Revision history for this message
Ryan Harkin (ryanharkin) wrote :

I don't know if "invalid" is the right thing here.

I *think* the idea is that the teams want to move to zImage/initrd and away from uImage/uInitrd. Soooo, I'd say that once we've got all images building with both zImage and uImage (done already?) then there should be a plan to update the configs in LAVA to boot zImages. I guess that involves updating the health check images.

(The latest UEFI binaries could be installed to allow the config to be updated without corrupting it ;-))

Assuming that works, then Tixy is intending to remove the uImage from the builds. The intention is to have *only* zImage in the build in future.

Revision history for this message
Antonio Terceiro (terceiro) wrote : Re: [Bug 1122088] Re: LAVA master image doesn't handle zImage and Initrd for android

On Mon, Feb 18, 2013 at 10:31:52AM -0000, Ryan Harkin wrote:
> I don't know if "invalid" is the right thing here.
>
> I *think* the idea is that the teams want to move to zImage/initrd and
> away from uImage/uInitrd. Soooo, I'd say that once we've got all images
> building with both zImage and uImage (done already?) then there should
> be a plan to update the configs in LAVA to boot zImages. I guess that
> involves updating the health check images.
>
> (The latest UEFI binaries could be installed to allow the config to be
> updated without corrupting it ;-))
>
> Assuming that works, then Tixy is intending to remove the uImage from
> the builds. The intention is to have *only* zImage in the build in
> future.

Are we talking about all boards, or only vexpress?

--
Antonio Terceiro
Software Engineer - Linaro
http://www.linaro.org

summary: - LAVA master image doesn't handle zImage and Initrd for android
+ Switch lab boards from uImage/uInitd to zImage/initrd
Changed in lava-lab:
status: Invalid → Confirmed
importance: High → Medium
milestone: 2013.02 → 2013.03
milestone: 2013.03 → 2013.02
Revision history for this message
Ryan Harkin (ryanharkin) wrote : Re: Switch lab boards from uImage/uInitd to zImage/initrd

Only vexpress.

summary: - Switch lab boards from uImage/uInitd to zImage/initrd
+ Switch vexpress boards from uImage/uInitd to zImage/initrd
Revision history for this message
Fathi Boudra (fboudra) wrote : Re: [Bug 1122088] Re: Switch lab boards from uImage/uInitd to zImage/initrd

On 18 February 2013 16:23, Antonio Terceiro <email address hidden> wrote:
> Are we talking about all boards, or only vexpress?

All boards supporting zImage. At the moment, we don't have a 100%
coverage of the boards available in the lab.
Let's start by Versatile Express only.

fyi, we plan to have single zImage kernel (+package, +hwpack, etc...)
support for March/April.

Changed in lava-lab:
milestone: 2013.02 → 2013.03
Revision history for this message
Antonio Terceiro (terceiro) wrote :

moving this to the backlog since 1) android builds now have uImage again, 2) we are not quite there yet regarding single zImage, and 3) I think it's better to change all boards together

Changed in lava-lab:
milestone: 2013.03 → backlog
Changed in lava-lab:
status: Confirmed → Invalid
Revision history for this message
Alan Bennett (akbennett) wrote :

This is no longer an issue based on other architectural changes in LAVA

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers