dd failed on ikshackbox master

Bug #1083090 reported by Naresh Kamboju on 2012-11-26
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
LAVA Validation Lab
Fix Released
High
Dave Pigott

Bug Description

dd failed on ikshackbox master
while copying ubuntu.img on to /dev/sda2 below error has been reported.
"fl source ubuntu" is not doing successful boot.
I think we may have to re-format the /dev/sda and copy ubuntu.img on to it.
or we may have to change the usb drive, if this error re-occurs again after re-format.

root@ikshackbox master:~# fdisk -l /dev/sda

Disk /dev/sda: 16.0 GB, 16008609792 bytes
128 heads, 32 sectors/track, 7633 cylinders, total 31266816 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

   Device Boot Start End Blocks Id System
/dev/sda1 * 63 106494 53216 c W95 FAT32 (LBA)
/dev/sda2 106496 4095999 1994752 83 Linux
root@ikshackbox master:~# dd if=ubuntu.img of=/dev/sda2
[ 240.997352] usb 1-1.2: device descriptor read/all, error -110
[ 256.167129] usb 1-1.2: device descriptor read/64, error -110
[ 271.366963] usb 1-1.2: device descriptor read/64, error -110
[ 276.586853] usb 1-1.2: device descriptor read/8, error -110
[ 281.726785] usb 1-1.2: device descriptor read/8, error -110
[ 286.946742] usb 1-1.2: device descriptor read/8, error -110
[ 292.086683] usb 1-1.2: device descriptor read/8, error -110
[ 292.227345] end_request: I/O error, dev sda, sector 603112
[ 292.243885] Buffer I/O error on device sda2, logical block 57631
[ 292.261975] Buffer I/O error on device sda2, logical block 57632
[ 292.279975] Buffer I/O error on device sda2, logical block 57633
[ 292.297972] Buffer I/O error on device sda2, logical block 57634
[ 292.315967] Buffer I/O error on device sda2, logical block 57635
[ 292.333962] Buffer I/O error on device sda2, logical block 57636
[ 292.351958] Buffer I/O error on device sda2, logical block 57637
[ 292.369953] Buffer I/O error on device sda2, logical block 57638
[ 292.387948] Buffer I/O error on device sda2, logical block 57639
[ 292.405944] Buffer I/O error on device sda2, logical block 57640
dd: writing to `/dev/sda2': Input/output error
496617+0 records in
496616+0 records out
254267392 bytes (254 MB) copied, 229.385 s, 1.1 MB/s
root@ikshackbox master:~# [ 308.116561] usb 1-1.2: device descriptor read/64, error -110
[ 323.316393] usb 1-1.2: device descriptor read/64, error -110
[ 338.596225] usb 1-1.2: device descriptor read/64, error -110
[ 353.796064] usb 1-1.2: device descriptor read/64, error -110
[ 359.015958] usb 1-1.2: device descriptor read/8, error -110
[ 364.155905] usb 1-1.2: device descriptor read/8, error -110
[ 369.375850] usb 1-1.2: device descriptor read/8, error -110
[ 374.515781] usb 1-1.2: device descriptor read/8, error -110
[ 374.635855] hub 1-1:1.0: unable to enumerate USB device on port 2

root@ikshackbox master:~#
root@ikshackbox master:~#reboot
....
Unable to find boot script - BOOTSCRIPT
>fl source ubuntu
Running script from flash - ubuntu
....
Begin: Mounting root file system ... Begin: Running /scripts/local-top ... done.
Begin: Running /scripts/local-premount ... done.
mount: mounting /dev/sda2 on /root failed: Invalid argument

BusyBox v1.18.5 (Ubuntu 1:1.18.5-1ubuntu4) built-in shell (ash)
Enter 'help' for a list of built-in commands.

(initramfs)

complete log can be found at

https://pastebin.linaro.org/1117/

Naresh Kamboju (naresh-kamboju) wrote :

i have tried below command as well
root@ikshackbox master:~# dd if=ubuntu.img of=/dev/sda

description: updated
Dave Pigott (dpigott) on 2012-11-26
Changed in lava-lab:
assignee: nobody → Dave Pigott (dpigott)
milestone: none → 2011.11
status: New → In Progress
Naresh Kamboju (naresh-kamboju) wrote :

this is one of the blockers for me to do testing on TC2.
I request you to fix this problem.

On 27 November 2012 16:10, Naresh Kamboju wrote:
> this is one of the blockers for me to do testing on TC2.
> I request you to fix this problem.

Dave is assigned and bug is targeted to be fixed soon.
Please, be patient. Feel free to ping on IRC for ETA.

Thanks.

Changed in lava-lab:
importance: Undecided → High
Fathi Boudra (fboudra) on 2013-01-09
Changed in lava-lab:
status: In Progress → Fix Released
Naresh Kamboju (naresh-kamboju) wrote :

I have verified this bug has been fixed.
fdisk /dev/sda
and removed all old partitions and re-formatted again.

-Naresh

Changed in lava-lab:
status: Fix Released → Fix Committed
Fathi Boudra (fboudra) on 2013-01-10
Changed in lava-lab:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers