"able_transfer_file_LAVA-WiFiTest01_wext" failed on Linaro ubuntu image.

Bug #1011975 reported by Botao on 2012-06-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
LAVA Validation Lab
Fix Released
Medium
Dave Pigott

Related branches

Botao (botao-sun) wrote :
summary: - "able_transfer_file_LAVA-WiFiTest01_wext" from test "wifi-enablement"
- failed on Origen ubuntu image.
+ "able_transfer_file_LAVA-WiFiTest01_wext" failed on Linaro ubuntu image.
description: updated
Paul Larson (pwlars) wrote :

I believe this is actually a lab infrastructure problem. That URL get's me a 401 when trying to access it from inside the lab. I tried to get on the router with the last password I knew about for it to see if I could open it up for download at that location, or to see if it was even the right router, but I couldn't log in.

Changed in lava-lab:
status: New → Confirmed
Andy Doan (doanac) wrote :
Changed in lava-lab:
assignee: nobody → Dave Pigott (dpigott)
milestone: none → 2012.06
Ricardo Salveti (rsalveti) wrote :

Yeah, this is probably because the usb stick is not available anymore for the wifi router. At the past this file was available at a pen-drive, which would be available from the router itself.

Dave Pigott (dpigott) wrote :

Ah, yes. This is because I used one of my own USB pen drive in the past and when we moved I put it back in my pocket and then never deployed a new one! Oops. Can someone point me at the image data that needs to be on a pen drive and I'll get it back up and running.

On Mon, Jun 25, 2012 at 4:31 AM, Dave Pigott <email address hidden> wrote:
> Ah, yes. This is because I used one of my own USB pen drive in the past
> and when we moved I put it back in my pocket and then never deployed a
> new one! Oops. Can someone point me at the image data that needs to be
> on a pen drive and I'll get it back up and running.

You can find the video at
http://samplemedia.linaro.org/MPEG4/big_buck_bunny_1080p_MPEG4_MP3_25fps_7600K.AVI

Please make sure the path at the pendrive is compatible with
http://readyshare.routerlogin.net/shares/USB_Storage/samplemedia.linaro.org/MPEG4/big_buck_bunny_1080p_MPEG4_MP3_25fps_7600K.AVI

Fathi Boudra (fboudra) on 2012-06-26
no longer affects: linaro-ubuntu

Dave Pigott
Validation Engineer
T: +44 1223 40 00 63 | M +44 7940 45 93 44
Linaro.org │ Open source software for ARM SoCs
Follow Linaro: Facebook | Twitter | Blog

On 26 Jun 2012, at 05:44, Ricardo Salveti wrote:

> On Mon, Jun 25, 2012 at 4:31 AM, Dave Pigott <email address hidden> wrote:
>> Ah, yes. This is because I used one of my own USB pen drive in the past
>> and when we moved I put it back in my pocket and then never deployed a
>> new one! Oops. Can someone point me at the image data that needs to be
>> on a pen drive and I'll get it back up and running.
>
> You can find the video at
> http://samplemedia.linaro.org/MPEG4/big_buck_bunny_1080p_MPEG4_MP3_25fps_7600K.AVI
>
> Please make sure the path at the pendrive is compatible with
> http://readyshare.routerlogin.net/shares/USB_Storage/samplemedia.linaro.org/MPEG4/big_buck_bunny_1080p_MPEG4_MP3_25fps_7600K.AVI

Will do. I have some pen drives on order (none spare right now) which should come tomorrow.

Thanks

Dave

Dave Pigott (dpigott) wrote :

Pen drives arrived, and I deployed into that directory hierarchy. However, even though the directory on the pen drive is named MPEG4 in uppercase, it only seems to appear as mpeg4 in lowercase on the web request. Does this cause a problem? If so I'll investigate further.

Fathi Boudra (fboudra) on 2012-06-29
Changed in lava-lab:
milestone: 2012.06 → 2012.07
Fathi Boudra (fboudra) on 2012-07-02
Changed in lava-lab:
importance: Undecided → Medium
Paul Larson (pwlars) wrote :

Still seems to be failing, see: http://validation.linaro.org/lava-server/dashboard/streams/anonymous/plars/bundles/b4e5c9b739e5749b7cd51b0918932704cb447477/5a00ee12-c538-11e1-ba32-2e4070f01206/attachments/86597/

Not sure if the case is the cause of it or not, and it's kinda hard for me to try it remotely since I don't have wifi access to that WAP.

Dave Pigott (dpigott) wrote :

Yes, it's the case of "MPEG4" that's causing the trouble. I've taken the USB stick out and checked, and it's definitely in upper case as far as the FS is concerned, so I formatted a new USB stick and re-deployed, but still the browser interface insists on it being in lower case. I've checked the router settings and there's nothing there about allowing case.

This is very odd because this used to work (unless we referenced in lower case before?) What's also odd is that the file name is case sensitive, and that works just fine.

I'll do some searching online and see if there's any reference to this problem. In the meantime, how much work is involved in changing "MPEG4" to "mpeg4" in the tests?

About this hard? https://code.launchpad.net/~mwhudson/linaro-ubuntu/lava-test-wifi-enablement/+merge/113679 (I don't know if that changes it to the URL that's actually currently accessible of course).

Dave Pigott (dpigott) wrote :

I assumed it was trivial. That is the currently available url, so it should now work. Can someone submit this modified test?

Botao (botao-sun) wrote :

For Panda 4430 board, "able_transfer_file_LAVA-WiFiTest01_wext" passed. Now only "able_transfer_file_LAVA-WiFiTest01_nl80211" failed. Observed on hardware pack:

http://snapshots.linaro.org/precise/hwpacks/lt-panda-x11-base/177/hwpack_linaro-lt-panda-x11-base_20120715-177_armhf_supported.tar.gz

with ubuntu rootfs image:

http://snapshots.linaro.org/precise/images/ubuntu-desktop/289/linaro-precise-ubuntu-desktop-20120715-289.tar.gz

Detailed log output can be found here:

http://validation.linaro.org/lava-server/dashboard/streams/private/team/linaro/pre-built-leb-panda-4430/bundles/33b34550ca09d844ab71aaf5c6c82f5af4ed9159/f4347e5e-ced9-11e1-9f98-2e404ebc6c0a/

has_wireless_device_LAVA-WiFiTest01_nl80211: PASS
able_put_iface_down_LAVA-WiFiTest01_nl80211: PASS
able_put_iface_up_LAVA-WiFiTest01_nl80211: PASS
able_scan_aps_LAVA-WiFiTest01_nl80211: PASS
able_scan_find_target_ap_LAVA-WiFiTest01_nl80211: PASS
able_start_wpa_supplicant_LAVA-WiFiTest01_nl80211: PASS
able_add_iface_wpa_supplicant_LAVA-WiFiTest01_nl80211: PASS
able_add_network_wpa_supplicant_LAVA-WiFiTest01_nl80211: PASS
able_set_network_wpa_supplicant_LAVA-WiFiTest01_nl80211: PASS
able_enable_network_wpa_supplicant_LAVA-WiFiTest01_nl80211: PASS
able_associate_ap_wpa_supplicant_LAVA-WiFiTest01_nl80211: PASS
able_get_ip_dhclient_LAVA-WiFiTest01_nl80211: PASS
able_transfer_file_LAVA-WiFiTest01_nl80211: FAIL - fail to download http://readyshare.routerlogin.net/shares/USB_Storage/samplemedia.linaro.org/MPEG4/big_buck_bunny_1080p_MPEG4_MP3_25fps_7600K.AVI
able_terminate_wpa_supplicant_LAVA-WiFiTest01_nl80211: PASS
has_wireless_device_LAVA-WiFiTest01_wext: PASS
able_put_iface_down_LAVA-WiFiTest01_wext: PASS
able_put_iface_up_LAVA-WiFiTest01_wext: PASS
able_scan_aps_LAVA-WiFiTest01_wext: PASS
able_scan_find_target_ap_LAVA-WiFiTest01_wext: PASS
able_start_wpa_supplicant_LAVA-WiFiTest01_wext: PASS
able_add_iface_wpa_supplicant_LAVA-WiFiTest01_wext: PASS
able_add_network_wpa_supplicant_LAVA-WiFiTest01_wext: PASS
able_set_network_wpa_supplicant_LAVA-WiFiTest01_wext: PASS
able_enable_network_wpa_supplicant_LAVA-WiFiTest01_wext: PASS
able_associate_ap_wpa_supplicant_LAVA-WiFiTest01_wext: PASS
able_get_ip_dhclient_LAVA-WiFiTest01_wext: PASS
able_transfer_file_LAVA-WiFiTest01_wext: PASS
able_terminate_wpa_supplicant_LAVA-WiFiTest01_wext: PASS

Dave Pigott (dpigott) wrote :

Re-deployed USB image, and modified file path in test.

Changed in lava-lab:
status: Confirmed → Fix Released
Botao (botao-sun) wrote :

For Snowball board, on hardware pack:

http://snapshots.linaro.org/precise/hwpacks/lt-snowball-x11-base/256/hwpack_linaro-lt-snowball-x11-base_20120814-256_armhf_supported.tar.gz

with ubuntu image:

http://snapshots.linaro.org/precise/images/ubuntu-desktop/352/linaro-precise-ubuntu-desktop-20120814-352.tar.gz

LAVA Job ID is:

http://validation.linaro.org/lava-server/scheduler/job/29302

"able_transfer_file_LAVA-WiFiTest01_nl80211" failed, detailed log output can be found here:

http://validation.linaro.org/lava-server/dashboard/streams/private/team/linaro/pre-built-leb-snowball/bundles/bdc4e879137615f3f83ae56663d3e62ea3b69097/38b3ba04-e659-11e1-a970-a9887e7eed71/attachments/120445/

has_wireless_device_LAVA-WiFiTest01_nl80211: PASS
able_put_iface_down_LAVA-WiFiTest01_nl80211: PASS
able_put_iface_up_LAVA-WiFiTest01_nl80211: PASS
able_scan_aps_LAVA-WiFiTest01_nl80211: PASS
able_scan_find_target_ap_LAVA-WiFiTest01_nl80211: PASS
able_start_wpa_supplicant_LAVA-WiFiTest01_nl80211: PASS
able_add_iface_wpa_supplicant_LAVA-WiFiTest01_nl80211: PASS
able_add_network_wpa_supplicant_LAVA-WiFiTest01_nl80211: PASS
able_set_network_wpa_supplicant_LAVA-WiFiTest01_nl80211: PASS
able_enable_network_wpa_supplicant_LAVA-WiFiTest01_nl80211: PASS
able_associate_ap_wpa_supplicant_LAVA-WiFiTest01_nl80211: PASS
able_get_ip_dhclient_LAVA-WiFiTest01_nl80211: PASS
able_transfer_file_LAVA-WiFiTest01_nl80211: FAIL - fail to download http://readyshare.routerlogin.net/shares/USB_Storage/samplemedia.linaro.org/mpeg4/big_buck_bunny_1080p_MPEG4_MP3_25fps_7600K.AVI
able_terminate_wpa_supplicant_LAVA-WiFiTest01_nl80211: PASS
has_wireless_device_LAVA-WiFiTest01_wext: PASS
able_put_iface_down_LAVA-WiFiTest01_wext: PASS
able_put_iface_up_LAVA-WiFiTest01_wext: PASS
able_scan_aps_LAVA-WiFiTest01_wext: PASS
able_scan_find_target_ap_LAVA-WiFiTest01_wext: PASS
able_start_wpa_supplicant_LAVA-WiFiTest01_wext: PASS
able_add_iface_wpa_supplicant_LAVA-WiFiTest01_wext: PASS
able_add_network_wpa_supplicant_LAVA-WiFiTest01_wext: PASS
able_set_network_wpa_supplicant_LAVA-WiFiTest01_wext: PASS
able_enable_network_wpa_supplicant_LAVA-WiFiTest01_wext: PASS
able_associate_ap_wpa_supplicant_LAVA-WiFiTest01_wext: PASS
able_get_ip_dhclient_LAVA-WiFiTest01_wext: PASS
able_transfer_file_LAVA-WiFiTest01_wext: PASS
able_terminate_wpa_supplicant_LAVA-WiFiTest01_wext: PASS

Changed in lava-lab:
status: Fix Released → New
Dave Pigott (dpigott) wrote :

I don't understand why this is still failing, if it is, because I can certainly get that file with that path. Can someone confirm if this is still failing?

Changed in lava-lab:
status: New → Incomplete
Fathi Boudra (fboudra) wrote :

Mark fix-released. File can be downloaded.
Verified on PandaBoard job: http://validation.linaro.org/lava-server/scheduler/job/33472/log_file

Changed in lava-lab:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers