uuid generation is unreliable

Bug #934164 reported by Deepti B. Kalakeri on 2012-02-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
LAVA Dispatcher
Won't Fix
Critical
Unassigned
Obsolete LAVA Test
Won't Fix
Critical
Zygmunt Krynicki

Bug Description

lava-test fails to complete for beagle board hwpack. Here is the traceback of the error:

Cause

A test with UUID 2600f98a-4f00-11e1-98b8-376b2c52277f already exists

Deserialization failure traceback

Traceback (most recent call last):
  File "/srv/lava/instances/production/local/lib/python2.7/site-packages/dashboard_app/models.py", line 483, in deserializeself._do_deserialize(prefer_evolution)
  File "/srv/lava/instances/production/local/lib/python2.7/site-packages/dashboard_app/models.py", line 504, in _do_deserializehelper.deserialize(self,prefer_evolution)
  File "/srv/lava/instances/production/local/lib/python2.7/site-packages/dashboard_app/helpers.py", line 757, in deserializeimporter().import_document(s_bundle,doc)
  File "/srv/lava/instances/production/local/lib/python2.7/site-packages/dashboard_app/helpers.py", line 62, in import_documentself._import_sanity_check(doc)
  File "/srv/lava/instances/production/local/lib/python2.7/site-packages/dashboard_app/helpers.py", line 95, in _import_sanity_checkraiseValueError("A test with UUID {0} already exists".format(analyzer_assigned_uuid))ValueError: A test with UUID 2600f98a-4f00-11e1-98b8-376b2c52277f already exists

The above error shows that the tests are failing because of duplicate uuid.
The uuid are not part of the json file the is submitted for test, hence it must be something which the lava assigns automatically.
This is blocking the beagle board testing for quite sometime now and needs to be fixed ASAP.

Related branches

Zygmunt Krynicki (zyga) wrote :

I think we need to change how uuids are generated when the dispatcher is used. IMHO we should return to uuid1() - based on MAC and current time and pass the UUID to the lava-test invocation.

Changed in lava-dispatcher:
importance: Undecided → Critical
status: New → Confirmed
summary: - Lava tests fail to complete because of Deserialization error
+ uuid genration is unreliable
Changed in lava-test:
importance: Undecided → Critical
status: New → Confirmed

Deepti, just out of curiosity, can you point to some of the test runs where you saw this happening?

Changed in lava-test:
milestone: none → 2012.03
Changed in lava-dispatcher:
milestone: none → 2012.03
assignee: nobody → Zygmunt Krynicki (zkrynicki)
Changed in lava-test:
assignee: nobody → Zygmunt Krynicki (zkrynicki)
Zygmunt Krynicki (zyga) on 2012-03-06
Changed in lava-test:
status: Confirmed → Fix Committed
Zygmunt Krynicki (zyga) on 2012-03-23
Changed in lava-test:
status: Fix Committed → Fix Released
Changed in lava-dispatcher:
milestone: 2012.03 → 2012.04
Fathi Boudra (fboudra) on 2012-04-27
Changed in lava-dispatcher:
milestone: 2012.04 → 2012.05
summary: - uuid genration is unreliable
+ uuid generation is unreliable
Zygmunt Krynicki (zyga) on 2012-06-07
Changed in lava-dispatcher:
status: Confirmed → In Progress
Fathi Boudra (fboudra) on 2012-06-07
Changed in lava-dispatcher:
milestone: 2012.05 → 2012.06
Fathi Boudra (fboudra) on 2012-06-27
Changed in lava-dispatcher:
assignee: Zygmunt Krynicki (zkrynicki) → nobody
status: In Progress → New
milestone: 2012.06 → none
Alan Bennett (akbennett) on 2013-06-03
Changed in lava-test:
status: Fix Released → Won't Fix
Changed in lava-dispatcher:
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers