Getting board ip address fails due to short timeout

Bug #1224359 reported by Dave Pigott on 2013-09-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
LAVA Dispatcher
Fix Released
High
Tyler Baker

Bug Description

I've seen this occasionally, mostly on Origens:

http://validation.linaro.org/scheduler/job/72326/log_file#L_27_0

Basically, the timeout of 5 seconds is sometimes not long enough, because the Origen is still busy with some initialisation. Perhaps we could make this a per device config, so that for more recent devices it can be the default of 5, but for older devices we can put it up to 10 or more.

Changed in lava-dispatcher:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Tyler Baker (tyler-baker)
Changed in lava-dispatcher:
status: Confirmed → Fix Committed
Changed in lava-dispatcher:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers