lava-test-runner calls distro-specific commands unconditionally

Bug #1154583 reported by Marcin Juszkiewicz on 2013-03-13
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
LAVA Dispatcher
Fix Released
High
Antonio Terceiro

Bug Description

There is lava-test-runner for Ubuntu and one for Android but there is no version for blackbox images - like OpenEmbedded ones for example.

So I used Ubuntu one. It has few assumptions which may be not fulfilled by OE:

<LAVA_TEST_RUNNER>: started
<LAVA_TEST_RUNNER>: looking for installation work in /lava/lava-test-runner.conf-1363170253
<LAVA_TEST_RUNNER>: save hardware/software context info...
cat: can't open '/etc/lsb-release': No such file or directory
/lava/bin/lava-test-runner: line 27: dpkg-query: command not found

full log: http://validation.linaro.org/lava-server/scheduler/job/49673/log_file

Someone can say "live with it" but I would prefer to not have non-related errors in log just because there is no proper tool

Related branches

Antonio Terceiro (terceiro) wrote :

Yes - having distro-dependent code there is wrong and we should fix it.

Or, at least, we should check for the availability of the stuff we need before actually calling them.

Changed in lava-dispatcher:
importance: Undecided → High
status: New → Confirmed
assignee: nobody → Antonio Terceiro (terceiro)
milestone: none → 2013.03
Antonio Terceiro (terceiro) wrote :

the linked branch has a proposed solution - I still have to test it, though.

Marcin - could you provide a oe_swcontext shell function that does the right thing for OE?

Changed in lava-dispatcher:
status: Confirmed → In Progress
summary: - There is no blackbox version of lava-test-runner
+ lava-test-runner calls distro-specific commands unconditionally
Changed in lava-dispatcher:
status: In Progress → Fix Committed
Fathi Boudra (fboudra) on 2013-03-29
no longer affects: linaro-oe
Changed in lava-dispatcher:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers