NoReverseMatch error occurs when create a bundle stream with name "bundle stream""

Bug #802957 reported by Yongqin Liu
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
LAVA Dashboard (deprecated)
Fix Released
Medium
Zygmunt Krynicki

Bug Description

When create a bundle stream with name "test_bundle",
and then click the "Bundle Streams" link in "http://localhost/launch-control"
The NoReverseMatch error will happen.

Please reference the attachment for information.

This problem may have relation to file /usr/lib/pymodules/python2.6/dashboard_app/urls.py

Related branches

Revision history for this message
Yongqin Liu (liuyq0307) wrote :
Revision history for this message
Yongqin Liu (liuyq0307) wrote :

when i remove the "test_bundle" bundle stream, or change the name to test-bundle, there is no error.

Revision history for this message
Yongqin Liu (liuyq0307) wrote :

do the changes as below could resolve this problem.
but i have not check all the possiable place.
I only confirm the display of "http://localhost/launch-control/dashboard/streams/" page.

BEGIN----->
20:42:16 liuyq:dashboard_app$ diff urls.py urls.py.old
57c57
< url(r'^streams(?P<pathname>/[_a-zA-Z0-9/_-]+)$',
---
> url(r'^streams(?P<pathname>/[_a-zA-Z0-9/-]+)$',
60c60
< url(r'^streams(?P<pathname>/[a-zA-Z0-9/_-]+?)\+bundles$',
---
> url(r'^streams(?P<pathname>/[a-zA-Z0-9/-]+?)\+bundles$',
20:42:22 liuyq:dashboard_app$
<-----------END

Hope the information above can be help.

Revision history for this message
Zygmunt Krynicki (zyga) wrote :

Thanks for looking at this. Would you mind proposing a merge request with the change you did to urls.py? If you are not comfortable with bzr+launchpad workflow just say so and I'll fix this internally.

Thanks
ZK

Changed in lava-dashboard:
assignee: nobody → Zygmunt Krynicki (zkrynicki)
importance: Undecided → Medium
status: New → Confirmed
Revision history for this message
Yongqin Liu (liuyq0307) wrote :

I sorry that i don't know the workflow on merge.
If you tell me how to do that, i am very glad to do that.

May be i can follow the steps depicted in the page below and merge into "lp:lava-dashboard", but i am not sure:
https://wiki.linaro.org/Resources/HowTo/BZR
http://doc.bazaar.canonical.com/latest/en/tutorials/using_bazaar_with_launchpad.html

Revision history for this message
Zygmunt Krynicki (zyga) wrote :

Hi.

Awesome work, thank you very much for the patch.

To propose a merge request you should create a branch of a *project* (here lava-dashboard) and not a +junk branch, as you did, because launchpad does not know how which branch the merge would go to.

Could you please push your branch to something like: lp:~liuyq0307/lava-dashboard/bug802957 instead? Then go to the branch on launchpad and click on a "propose a merge request" link.

Alternatively I can just merge your branch manually (as the patch is correct).

Zygmunt Krynicki (zyga)
Changed in lava-dashboard:
status: Confirmed → In Progress
Zygmunt Krynicki (zyga)
Changed in lava-dashboard:
status: In Progress → Fix Committed
milestone: none → 11.07
Paul Larson (pwlars)
Changed in lava-dashboard:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.