Lava Android Test Runner

Problem in running out of tree test on lava server..

Reported by Prakash Ranjan on 2012-02-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
LAVA Android Test
Undecided
Unassigned

Bug Description

Hello all,
I have some problem on running out of tree test (in my case it is cpuhotplug test) from lava-test suits on lava server. The job file which I am using to install and register this test on lava server is http://paste.ubuntu.com/861504/ . In the mentioned job file the "temp-testapp.json" file is http://paste.ubuntu.com/861500/ .
While running this test on lava server I am getting the error like
"ERROR: There is no test with the specified ID " but lava-test is successfully installing. In the lava result bundle also "lava-test_install" is passed but lava-test_run(cpuhotplug) is failed.
To see the complete log please follow the link. http://paste.ubuntu.com/861841/
Any help on this issue is valuable for me.

description: updated
description: updated

I think the "file:///linaro/temp-testapp.json" needs to be an "http://...." URL so the LAVA target board can see it.

I use the people.linaro.org server to do this.

Prakash Ranjan (mailme-prak) wrote :

If the lava -target board can't see it through "file:///linaro/temp-testapp.json" syntax, then the lava test install should get failed because the registering part of out of tree test is inside the lava_test_install command. But in the lava -test output log file I am getting output as "lava_test_install successfully".

Prakash Ranjan (mailme-prak) wrote :

Thank you Andrew Stubbs... Your suggestion works .. But still my doubt is not clear. If it is failing in registering itself, then it should give error in lava -test install time only as i think... Any way thanks a lot....

Prakash Ranjan (mailme-prak) wrote :

Hello all ,
With Andrew suggestions now I am able to install and run the out of tree test but gathering result is getting failed. I guess something is wrong in parse pattern command of http://paste.ubuntu.com/862996/ file. Can anyone tell me what is wrong.

Dave Pigott (dpigott) wrote :

Surely, rather than filing bugs for this sort of question, they would be better targeted at answers.launchpad.net/lava.

If it turns out that you have identified a bug, rather than just being a configuration issue, then it can be entered as a bug.

Kishore Kanna S (kishorek-s) wrote :

Hello Anderw Stubbs,
       Did you face any problem on re installing or updating your out of tree test suits. Currently my condition is , I successfully installed and run my out of tree test suites but again when I am trying to re install it, error coming like " This test is already registered ." Here I am getting the point that ok, once it got registered so it is saying that it is already registered. But while running the test suit. "Error coming "There is no test with the specified ID". After getting this error i removed the .config /lava-test/registry.json file from my origen test image and tried again. But this time i did not get that error like " This test is registered", But i got the error while installing it like " There is no test with the specified ID". Do I am missing something. Even I tried to installed the the out of tree test on my origen board directly. There also I got the same error.

This is the log ouput:

optional arguments:
  -h, --help show this help message and exit
root@master:~# [rc=0]: chroot /mnt/testrootfs lava-test register-test http://192.168.0.10/linaro/temp_testapp.json
chroot /mnt/testrootfs lava-test register-test http://1 92.168.0.10/linaro/cpu.json
root@master:~# [rc=0]: chroot /mnt/testrootfs lava-test install cpuhot
chroot /mnt/testrootfs lava-test install cpuhot
ERROR: There is no test with the specified ID
root@master:~# [rc=1]: chroot /mnt/testrootfs rm -rf lava-test
chroot /mnt/testrootfs rm -rf lava-test
root@master:~# [rc=0]: cp -f /mnt/testrootfs/etc/resolv.conf.bak /mnt/testrootfs/etc/resolv.conf
cp -f /mnt/testrootfs/etc/resolv.conf.bak /mnt/testrootf s/etc/resolv.conf
root@master:~# [rc=0]: cat /proc/mounts | awk '{print $2}' | grep "^/mnt/testrootfs/dev"| sort -r | xargs umount
cat /proc/mounts | awk '{print $2}' | grep "^/mnt/testro otfs/dev"| sort -r | xargs umount
root@master:~# [rc=0]: umount /mnt/testrootfs
umount /mnt/testrootfs

root@master:~# [rc=0]: <LAVA_DISPATCHER>2012-03-02 04:56:16 AM INFO: [ACTION-E] lava_test_install is finished successfully.
<LAVA_DISPATCHER>2012-03-02 04:56:16 AM INFO: [ACTION-B] Command boot_linaro_image is started with parameters {}.
<LAVA_DISPATCHER>2012-03-02 04:56:16 AM INFO: Boot the test image
<LAVA_DISPATCHER>2012-03-02 04:56:16 AM INFO: Perform soft reboot the system

Please help me on this issue ...

Kishore Kanna S (kishorek-s) wrote :

Thank You all for helping me to run the out of tree test successfully. The above error I was getting because of error in .json file because of which it was not downloading the mentioned tar file..
Thank You once again...

Dave Pigott (dpigott) wrote :

I've taken the liberty of marking this as invalid, since it was not a bug but a configuration error. Try putting this sort of thing on ask.linaro.org, rather than filing it as a bug in future.

Changed in lava-android-test:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers