fails trying to download setuptools-0.6c8-py2.6.egg from a dead link (old

Bug #406366 reported by blep on 2009-07-29
This bug affects 1 person
Affects Status Importance Assigned to Milestone

Bug Description

Running from the latest released tarball:
launchpadlib-1.5.1>python install

Fails with:
Traceback (most recent call last):
  File "", line 22, in <module>
  File "C:\perso\tc\devtools\sf-tarball-sync\launchpadlib-1.5.1\", line 95, in use_setuptools
    return do_download()
  File "C:\perso\tc\devtools\sf-tarball-sync\launchpadlib-1.5.1\", line 89, in do_download
    egg = download_setuptools(version, download_base, to_dir, download_delay)
  File "C:\perso\tc\devtools\sf-tarball-sync\launchpadlib-1.5.1\", line 150, in download_setuptools
    src = urllib2.urlopen(url)
  File "c:\Python26\lib\", line 124, in urlopen
    return, data, timeout)
  File "c:\Python26\lib\", line 389, in open
    response = meth(req, response)
  File "c:\Python26\lib\", line 502, in http_response
    'http', request, response, code, msg, hdrs)
  File "c:\Python26\lib\", line 427, in error
    return self._call_chain(*args)
  File "c:\Python26\lib\", line 361, in _call_chain
    result = func(*args)
  File "c:\Python26\lib\", line 510, in http_error_default
    raise HTTPError(req.get_full_url(), code, msg, hdrs, fp)
urllib2.HTTPError: HTTP Error 404: Not Found

Following the instruction, I tried to download the file manually in the browser but it seems that it no longer exist:
Only the file:
exists. (c9 instead of c8).

Downloading the above file and placing it in the directory does not work.

blep (blep) wrote :

I found a work-around. Replacing ez_setup.y with the latest version from:
solved the problem.

Updating the installation instruction with the above work-around.

Changed in launchpadlib:
importance: Undecided → High
status: New → Fix Committed
status: Fix Committed → Triaged
summary: fails trying to download setuptools-0.6c8-py2.6.egg from a dead
- link
+ link (old
Robert Collins (lifeless) wrote :

There is a new ez-setup in the LP download cache.

tags: added: easy
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers