Anonymous API requests are not shown any bug activity

Bug #991079 reported by Gema Gomez on 2012-04-29
42
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Launchpad itself
Low
William Grant

Bug Description

I am trying to automate following up bugs activity, and when trying to retrieve activity for a bug, the api seems to return an empty set:

https://api.launchpad.net/1.0/bugs/934614/activity

For example here, this is the output:
{"total_size": 16, "start": 0, "entries": [], "resource_type_link" : "https://api.launchpad.net/1.0/#bug_activity-page-resource"}

I was expecting to see the 16 entries on the entry set. Is there a different place to retrieve the activity from and I am reading this wrongly?

Analysis
========

The API strips out inaccessible entries from collections, which is why the entries are empty in this case - they are all considered inaccessible to anonymous requests.

Related branches

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in launchpad:
status: New → Confirmed
summary: - Launchpad API doesn't return bug activity
+ Anonymous API requests are not shown any bug activity
Changed in launchpad:
status: Confirmed → Triaged
importance: Undecided → Low
description: updated
Curtis Hovey (sinzui) on 2012-04-30
tags: added: api bughistory bugs
William Grant (wgrant) on 2012-04-30
tags: added: trivial
Kit Randel (blr) on 2015-03-02
Changed in launchpad:
assignee: nobody → Bayard 'kit' Randel (blr)
William Grant (wgrant) on 2016-04-12
Changed in launchpad:
assignee: Kit Randel (blr) → nobody
William Grant (wgrant) on 2016-04-12
Changed in launchpad:
assignee: nobody → William Grant (wgrant)
status: Triaged → In Progress
Launchpad QA Bot (lpqabot) wrote :
tags: added: qa-needstesting
Changed in launchpad:
status: In Progress → Fix Committed
William Grant (wgrant) on 2016-04-15
tags: added: qa-ok
removed: qa-needstesting
William Grant (wgrant) on 2016-05-06
Changed in launchpad:
status: Fix Committed → Fix Released

Awesome! Works for me. Thanks William!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers