Cannot complete rocketfuel-setup in Precise

Bug #990191 reported by Cruz Bishop on 2012-04-27
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Launchpad itself
High
William Grant

Bug Description

Launchpad cannot be set up via rocketfuel-setup in Ubuntu Precise Pangolin (12.04) partialy due to an invalid version of Python being required. Also, the rabbitmq packages have trouble installing with broken dependencies

This is using a freshly updated version of Precise, with all updates installed before attempting to use rocketfuel-setup

Python 2.6 is not available in Precise, only 2.7 and 3.x are available. However, only Python 2.6 can be used to set Launchpad up

Also, rabbitmq-management cannot be installed

Some parts of the log are below, in sequence

Package `launchpad-developer-dependencies' is not installed and no info is available.

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 launchpad-developer-dependencies : Depends: launchpad-dependencies (= 0.111~precise1) but it is not going to be installed
                                    Depends: launchpad-messagequeue-dependencies (= 0.111~precise1) but it is not going to be installed
                                    Depends: launchpad-soyuz-dependencies (= 0.111~precise1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Unable to install launchpad-developer-dependencies.

The following packages have unmet dependencies:
 launchpad-soyuz-dependencies : Depends: launchpad-dependencies (= 0.111~precise1) but it is not going to be installed

-------------------------

The following packages have unmet dependencies:
 launchpad-dependencies : Depends: python2.6-dev but it is not installable
                          Depends: python2.6 but it is not installable

------------------------

The following packages have unmet dependencies:
 launchpad-messagequeue-dependencies : Depends: rabbitmq-management but it is not going to be installed

------------------------

The following packages have unmet dependencies:
 rabbitmq-management : Depends: rabbitmq-mochiweb but it is not going to be installed
                       Depends: rabbitmq-management-agent but it is not going to be installed
                       Depends: rabbitmq-server (< 2.6.2) but 2.7.1-0ubuntu4 is to be installed

The following packages have unmet dependencies:
 rabbitmq-mochiweb : Depends: rabbitmq-plugins-common but it is not installable
E: Unable to correct problems, you have held broken packages.

The following packages have unmet dependencies:
 rabbitmq-management-agent : Depends: rabbitmq-plugins-common but it is not installable

Package rabbitmq-plugins-common is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  rabbitmq-server

---------------------------------

Managed to fix the last error there, rabbitmq-server installed successfully. However, rabbitmq-mochiweb and rabbitmq-management-agent still won't install, requiring rabbitmq-plugins-common

---------------------------------

Gary Poster (gary) wrote :

Thank you for filing this bug.

While we do want Launchpad to run on Precise, and this bug is good to have to track that desire, you might be interested in running Launchpad in LXC (https://dev.launchpad.net/Running/LXC) which several LP developers use on Precise; or using a full-fledged Lucid VM (https://dev.launchpad.net/Running/VirtualMachine).

tags: removed: regression
Changed in launchpad:
status: New → Triaged
importance: Undecided → Low
importance: Low → High
Curtis Hovey (sinzui) on 2012-04-30
tags: added: infrastructure
removed: launchpad
William Grant (wgrant) on 2012-05-01
Changed in launchpad:
assignee: nobody → William Grant (wgrant)
status: Triaged → In Progress
William Grant (wgrant) on 2012-05-01
Changed in launchpad:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers