Suggestions menu next to "Choose..." doesn't do anything

Bug #97266 reported by Matthew Paul Thomas
20
Affects Status Importance Assigned to Milestone
Launchpad itself
Fix Released
High
Unassigned

Bug Description

1. Try to retarget an existing bug to the non-existent "launchpad-infrastructure" project.
2. On the resulting error page, observe that there is a menu of suggestions with two items: launchpad-development-infrastructure and qprocd.
3. Choose either of the items.

What was expected: The Launchpad ID of the selected item should be copied into the text field.
What happened: Nothing at all.

This is in Safari 1.3 with JavaScript turned on, but the same problem would occur in any browser with JavaScript turned off. A better solution would be to present the suggestions as text ("Did you mean: ___, ___, ___"), so that they can be copied and pasted into the field. Unobtrusive JavaScript can then turn the text into links that, when clicked, change the text in the field.

Changed in malone:
importance: Undecided → High
Revision history for this message
Jonathan Lange (jml) wrote :

I have confirmed this on Safara 2.0.4 on OS X 10.4

Changed in malone:
status: Unconfirmed → Confirmed
Revision history for this message
Jonathan Lange (jml) wrote :

Safari

Revision history for this message
Martin Pool (mbp) wrote :

Works for me in Jaunty Firefox, though I did hit bug 298000 that the error text next to the dropdown is wrong.

Curtis Hovey (sinzui)
affects: malone → launchpad-foundations
Curtis Hovey (sinzui)
affects: launchpad-foundations → launchpad-web
Changed in launchpad-web:
importance: High → Low
importance: Low → High
tags: added: confusing-ui
Revision history for this message
Curtis Hovey (sinzui) wrote :

This is still broken in Konqueor, chromium, and epiphany in Maverick.

tags: added: javascrcipt webkit
removed: confusing-ui
Curtis Hovey (sinzui)
tags: added: project-picker
Revision history for this message
Curtis Hovey (sinzui) wrote :

The onclick attrs added to the select options are not valid events for options. It works in gecko-based browsers by accident. This feature can be fixed by switching the to the standard onchange event for the select widget.

Changed in launchpad:
assignee: nobody → Curtis Hovey (sinzui)
status: Triaged → In Progress
Revision history for this message
Launchpad QA Bot (lpqabot) wrote :
tags: added: qa-needstesting
Changed in launchpad:
status: In Progress → Fix Committed
Curtis Hovey (sinzui)
tags: added: qa-ok
removed: qa-needstesting
William Grant (wgrant)
Changed in launchpad:
status: Fix Committed → Fix Released
Curtis Hovey (sinzui)
tags: added: target-picker
removed: project-picker
Curtis Hovey (sinzui)
Changed in launchpad:
assignee: Curtis Hovey (sinzui) → nobody
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers