Unable to figure out why I got mail about a question

Bug #968578 reported by Scott Kitterman on 2012-03-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
High
Colin Watson

Bug Description

It turns out that someone subscribed ubuntu-members to the question and then some unsubscribed ubuntu-members, so by the time I got to it there was no way to tell why I got this mail, since there's no way to tell in the message itself.

Return-Path: <email address hidden>
Received: from mailwash7.pair.com (66.39.2.7)
  by raung.pair.com with SMTP; 29 Mar 2012 18:46:04 -0000
Received: from localhost (localhost [127.0.0.1])
 by mailwash7.pair.com (Postfix) with SMTP id F3A19BAD8
 for <email address hidden>; Thu, 29 Mar 2012 14:46:03 -0400 (EDT)
X-Virus-Check-By: mailwash7.pair.com
X-Whitelisting: sender whitelisted by rule [.*@canonical\.com]
Received: from indium.canonical.com (indium.canonical.com [91.189.90.7])
 by mailwash7.pair.com (Postfix) with ESMTP id DABABBAD5
 for <email address hidden>; Thu, 29 Mar 2012 14:46:03 -0400 (EDT)
Received: from loganberry.canonical.com ([91.189.90.37])
 by indium.canonical.com with esmtp (Exim 4.71 #1 (Debian))
 id 1SDKME-00018L-Lx
 for <email address hidden>; Thu, 29 Mar 2012 18:46:02 +0000
Received: from loganberry.canonical.com (localhost [127.0.0.1])
 by loganberry.canonical.com (Postfix) with ESMTP id D079A2E8072
 for <email address hidden>; Thu, 29 Mar 2012 18:45:57 +0000 (UTC)
Content-Type: text/plain; charset="utf-8"
MIME-Version: 1.0
Content-Transfer-Encoding: quoted-printable
X-Launchpad-Question: product=launchpad; status=Open; assignee=None;
 priority=Normal; language=en
Reply-To: <email address hidden>
X-Launchpad-Message-Rationale: Subscriber
To: <email address hidden>
From: "marcobra \(Marco Braida\)" <email address hidden>
Subject: Re: [Question #192063]: @ubuntu.como mail does not work on the
 mailing list of Ubuntu
Message-Id: <email address hidden>
Date: Thu, 29 Mar 2012 18:45:57 -0000
Sender: <email address hidden>
Errors-To: <email address hidden>
Precedence: bulk
X-Generated-By: Launchpad (canonical.com); Revision="15032";
 Instance="launchpad-lazr.conf"
X-Launchpad-Hash: 177e02ec8bf1d30bc7c1c05ae189b2a650c53fec

Question #192063 on Launchpad itself changed:
https://answers.launchpad.net/launchpad/+question/192063

    Project: Ubuntu =3D> Launchpad itself

--=20
You received this question notification because you are a direct
subscriber of the question.

Related branches

Changed in launchpad:
status: New → Triaged
importance: Undecided → High
tags: added: email subscribers ui
Curtis Hovey (sinzui) wrote :

We established on IRC that one of your teams was momentarily added a question subscriber.

Changed in launchpad:
status: Triaged → Invalid
Scott Kitterman (kitterman) wrote :

Yes. I know that. The fact that it took hunting people down on IRC to figure it out is the bug.

Changed in launchpad:
status: Invalid → Confirmed
Changed in launchpad:
status: Confirmed → Triaged
summary: - Unable to figure out why I got mail
+ Unable to figure out why I got mail about a question
Colin Watson (cjwatson) on 2015-08-25
Changed in launchpad:
assignee: nobody → Colin Watson (cjwatson)
status: Triaged → In Progress
Launchpad QA Bot (lpqabot) wrote :
tags: added: qa-needstesting
Changed in launchpad:
status: In Progress → Fix Committed
Colin Watson (cjwatson) wrote :

This OOPSes as follows in some cases:

Traceback (most recent call last):
  Module lazr.jobrunner.jobrunner, line 194, in runJobHandleError
    self.runJob(job, fallback)
  Module lp.services.job.runner, line 302, in runJob
    super(BaseJobRunner, self).runJob(IRunnableJob(job), fallback)
  Module lazr.jobrunner.jobrunner, line 162, in runJob
    job.run()
  Module lp.answers.model.questionjob, line 239, in run
    formatted_body = self.buildBody(reason.getReason())
  Module lp.services.mail.basemailer, line 245, in getReason
    return (self.reason_template % self._getTemplateValues())
  Module lp.services.mail.basemailer, line 233, in _getTemplateValues
    assert self.recipient.hasParticipationEntryFor(self.subscriber), (
  Module lp.registry.model.person, line 1364, in hasParticipationEntryFor
    return bool(TeamParticipation.selectOneBy(person=self, team=team))
  Module storm.sqlobject, line 356, in selectOneBy
    return SQLObjectResultSet(cls, by=kwargs)._one()
  Module storm.sqlobject, line 516, in _one
    return detuplelize(self._result_set.one())
  Module storm.store, line 1161, in one
    result = self._store._connection.execute(select)
  Module storm.databases.postgres, line 266, in execute
    return Connection.execute(self, statement, params, noresult)
  Module storm.database, line 238, in execute
    raw_cursor = self.raw_execute(statement, params)
  Module storm.databases.postgres, line 276, in raw_execute
    return Connection.raw_execute(self, statement, params)
  Module storm.database, line 322, in raw_execute
    self._check_disconnect(raw_cursor.execute, *args)
  Module storm.database, line 371, in _check_disconnect
    return function(*args, **kwargs)
ProgrammingError: permission denied for relation teamparticipation

tags: added: qa-bad
removed: qa-needstesting
Colin Watson (cjwatson) on 2015-08-26
Changed in launchpad:
status: Fix Committed → In Progress
Launchpad QA Bot (lpqabot) wrote :
tags: added: qa-needstesting
removed: qa-bad
Changed in launchpad:
status: In Progress → Fix Committed
Colin Watson (cjwatson) on 2015-08-26
tags: added: qa-ok
removed: qa-needstesting
Colin Watson (cjwatson) on 2015-09-01
Changed in launchpad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers