<email address hidden> is spamming launchpad translators

Bug #967936 reported by Olly Betts
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Launchpad itself
High
Laura Czajkowski

Bug Description

I'm not sure if there's much you can do about it, but I asked on
#launchpad and lifeless suggested filing a bug, so here's the mail
I received:

----- Forwarded message from "Vector.us Translation" <email address hidden> -----

From: "Vector.us Translation" <email address hidden>
To: <email address hidden>
Subject: Translators Needed at Vector.us
Date: Thu, 29 Mar 2012 01:14:10 -0000
X-Sendgrid-EID: PDmqCz5PqoN1AbEj4zbObxQMRPzxA03c8+rqebIN430EVLJPPecKuBN12IyoPtQ3xBQeGD7X3ZooNu62uk8mrLdNOXLmsDYerrK2xqi4uLgdPabhLhM/cHcygHpYHkzr/OImECHBBbHg+OIbvmyovQ==

Hi Olly Betts,

I saw you involved in French translations for Survex Cave Mapping Software at Launchpad so I would like to ask if you could help me out in translating Vector.us.

Vector.us is a search engine for free vector graphics with probably the most extensive database of free vector arts. I created a simple web-based translation system similar to Launchpad's at http://vector.us/translate. Currently around 160 translators are already on board.

If you would like to contribute, please reply to this message and I will create a translator account for you. Or just ignore it and you wont receive any messages from us.

Every translator will get a link from Vector.us at http://vector.us/translate/contributors. We will appreciate your efforts to make this site more native to all people around the world!

Greetings

Henry
Vector.us Team
http://vector.us
http://twitter.com/vectorfiles
<email address hidden>

----- End forwarded message -----

Analysis
========

Vector probably got the email address from PO files exported to Ubuntu. We include contributor email addresses in those files unless the address is totally hidden (see bug 362848). If we were to use a pointer into LP as that bug discusses, this would be less trivial - and this would also avoid a vector leading to these email addressses getting into search engines.

It is possible to solve only one of these symptoms, so keeping as two bugs for now.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in launchpad:
status: New → Confirmed
Changed in launchpad:
assignee: nobody → Laura Czajkowski (czajkowski)
status: Confirmed → In Progress
importance: Undecided → High
Revision history for this message
Laura Czajkowski (czajkowski) wrote :

I've mailed the organisation in question to notify them of the issue. I've spoken to Lifeless on IRC and we need to look at why this is happening to the translation mailing list

tags: added: email mailing-lists
Revision history for this message
Curtis Hovey (sinzui) wrote :

this is not a bug in Lp code. No code changes need to be deployed to suspend a user.

Changed in launchpad:
status: In Progress → Invalid
Revision history for this message
Robert Collins (lifeless) wrote :

We are leaking email addresses in a way users may not be expecting.

Changed in launchpad:
status: Invalid → Triaged
description: updated
Revision history for this message
Olly Betts (ojwb) wrote :

I don't believe I'm subscribed to any translation mailing lists - I think these jokers are scraping email addresses for people who are shown in launchpad as having worked on translations, presumably by creating a launchpad account.

(Despite the contents of the email I forwarded, I don't actually speak French nearly well enough to translate to it, but I've uploaded existing translations for Survex to launchpad, so it shows me as having worked on them.)

Revision history for this message
Olly Betts (ojwb) wrote :

Oh, I only just saw the analysis about exported PO files in the description. That sounds quite plausible too.

Curtis Hovey (sinzui)
tags: removed: mailing-lists
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions