bug task creation date is not selectable for display and thus can no longer be sorted by

Bug #896539 reported by Michael Bienia on 2011-11-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
Low
Unassigned

Bug Description

With the new dynamic bug listing I don't seem so be able to sort by "newest first" anymore (it still accessible through the advanced search).

I use the "newest first" ordering to check if a bug got already filed about a package upgrade issue in the development release.

Michael Bienia (geser) on 2011-11-26
tags: added: bug-columns
Aaron Bentley (abentley) wrote :

Sorting by descending bug number is the same as sorting by "newest first".

Changed in launchpad:
status: New → Invalid
Robert Collins (lifeless) wrote :

No its not. bug number is creation of the bug,. newest first is creation of the task.

tags: added: regression
Changed in launchpad:
status: Invalid → Triaged
importance: Undecided → High
importance: High → Critical
Robert Collins (lifeless) wrote :

See lib/lp/bugs/model/bugtask.py getOrderByColumnDBName and lib/lp/bugs/templates/bugtarget-macros-search.pt to join the dots here.

Aaron Bentley (abentley) wrote :

This will be solved when bug #898200 is fixed.

Abel Deuring (adeuring) wrote :

The fix for bug 898200 does not solve this issue: We do not offer to display BugTask.datecreated, but we allow only sorting by fields that are displayed.

So: Should we extend the set of fields we display, or should we extend just the sort options? I prefer the former, because not showing the sort value makes it hard to answer the question "how far away from the start/end of the result set is the data in the current batch?" Specifically in this case: "How old is this bug task?"

Deryck Hodge (deryck) wrote :

We made an explicit choice in the design of this feature to have a 1-for-1 relationships between the things displayed and the sort options, knowing that we could support any additional sort options via the advanced search page. We understood that some options previously supported would be dropped from the top-level simple search page, and we discussed this one in particular. The thinking was that most people don't know "newest" is tracked by bugtask rather than bug age, that most people expect newest to be based on the bug created date, and that a bug age sort would match most people's use case and expectations.

I will mark this bug won't fix since it's not something we intend to change, but I do understand this is inconvenient for those who need sort on bugtask age and not bug. I'm sorry for that inconvenience, but it is at least still possible from the advanced search page.

Abel is doing some work to fix the bugs around coming to a search results page from an advanced search, but I'd like for him to open a new bug for that work, if it's not already covered by another bug, rather than trying to repurpose this bug.

Changed in launchpad:
status: Triaged → Won't Fix
Robert Collins (lifeless) wrote :

Deryck and I chatted on IRC; it should be straight forward to expose the date the task was created as a new item of bug info, which would allow folk wanting this to use it easily (and makes it more useful because you can tell when you're looking at ancient stuff). Per that discussion I've reopened and retitled.

Changed in launchpad:
status: Won't Fix → Triaged
summary: - Dynamic bug listing doesn't allow any easy way to sort by "newest first"
- anymore
+ bug task creation date is not selectable for display and thus can no
+ longer be sorted by
Matthew Revell (matthew.revell) wrote :

Michael, can you tell me what you want from "newest first". Do you want to see bugs ordered by when the bug itself was created or, if it's a different time/date , ordered by when it was marked as affecting the package that interests you.

Deryck Hodge (deryck) wrote :

I support keeping the bug around to track the request to support this use case, but we intentionally made this change and can't really call it a regression the same way we do other regressions. I'm marking it LOW for now, and if Matthew deems we should work on it before leaving beta, we can upgrade to HIGH.

Changed in launchpad:
importance: Critical → Low
tags: removed: regression
Michael Bienia (geser) wrote :

My use case is when I stumble upon a package upgrade issue, I check the recently opened bugs if it's already filed before filing it.
As the default bug order is "by importance" and such a bug might be or might not be classified already (and therefore get sorted at different positions in the bug listing (high, low, unclassified)), it's much easier to spot an already opened bug by sorting "newest first".

I guess for my use case sorting by bug number works too as such bugs very seldom get additional bug task much later. The old advanced search didn't offer an ordering by bug number (the closest was "newest first"), so I looked for an similar sorting option in the new interface too.

William Grant (wgrant) on 2015-09-11
tags: added: bug-search
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers