Package picker: "too many matches" although searching for specific package

Bug #893796 reported by SwitchDK on 2011-11-22
46
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Launchpad itself
Low
Colin Watson

Bug Description

When attempting to search for a package using Launchpad's "Choose" function "Too many matches. Please try to narrow your search." is reported although the search is for a specific package (please see attachment for screenshot).

To reproduce the problem do the following:

1. Open an existing bug for Ubuntu
2. Click the downward arrow under "Affects" next to Project
3. Type "xorg" in Package field
4. Click "Choose..."
5. The "Select a Package" window appears stating "Too many matches..."

I would expect that "Select a Package" would do one of the following:
- Return one package (the matching package); or
- Close the "Select a Package" window and enter the searched package in the Package field; or
- Show suggestions/options for narrowing down the xorg package

At the moment, a user would conclude that it is not possible to report a bug against "xorg" since it is not possible to determine if "xorg" is indeed the correct package or some other package must be selected, which can't be viewed due to "Too many matches..."

If any information is missing please let me know and I will add it as soon as possible.

Thank you,

Peter Dam (SwitchDK)

Related branches

SwitchDK (switchdk) wrote :
Brian Murray (brian-murray) wrote :

One thing that may lead to some confusion here is that its not clear that clicking "(Choose...)" is optional.

summary: - "too many matches" although searching for specific package
+ Project picker: "too many matches" although searching for specific
+ package
Changed in launchpad:
importance: Undecided → High
status: New → Triaged
summary: - Project picker: "too many matches" although searching for specific
+ Package picker: "too many matches" although searching for specific
package
Curtis Hovey (sinzui) wrote :

The bug is fixed in the new DSP vocab. We officially stopped work on it. I have landed some fixes. We are about 2 branches away from replacing the old package pickers that timeout, list the wrong, packages, search the wrong data.

tags: added: target-picker
tags: added: vocabulary
Changed in launchpad:
importance: High → Low
tags: added: search
SoloTurn (soloturn) wrote :

how much time do you mean by "2 branches away"?

M Oberhauser (zomtir) wrote :

Same happens if you search for the unity package in Ubuntu

Colin Watson (cjwatson) on 2016-09-12
Changed in launchpad:
assignee: nobody → Colin Watson (cjwatson)
status: Triaged → In Progress
Launchpad QA Bot (lpqabot) wrote :
tags: added: qa-needstesting
Changed in launchpad:
status: In Progress → Fix Committed
Colin Watson (cjwatson) on 2016-09-19
tags: added: qa-ok
removed: qa-needstesting
Colin Watson (cjwatson) on 2016-09-19
Changed in launchpad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers