sourceforge imports fail due to connection hangup

Bug #891887 reported by Jelmer Vernooij on 2011-11-18
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Bazaar Subversion Plugin
High
Unassigned
Launchpad itself
High
Jelmer Vernooij

Bug Description

SourceForge randomly hangs up HTTP/HTTPS connections, causing code imports - especially code imports of large svn repositories - to fail.

An obvious workaround for this is to import a smaller number of revisions in each batch, lowering the chance that one of the revisions in the batch will be affected. We can either tweak the global svn batch size setting - but this then means initial big svn imports from other locations will take longer - or add a flag to CodeImport.

bzr-svn can probably also try to commit the changes that have already been processed, for a set of known errors.

Related branches

Jelmer Vernooij (jelmer) on 2011-11-18
Changed in bzr-svn:
status: New → Triaged
importance: Undecided → High
assignee: nobody → Jelmer Vernooij (jelmer)
description: updated
Curtis Hovey (sinzui) wrote :

IS this a duplicate of bug 682430?

Brad Crittenden (bac) on 2011-11-18
Changed in launchpad:
status: New → Incomplete

Am 18/11/11 15:08, schrieb Curtis Hovey:
> IS this a duplicate of bug 682430?
>
Sortof, I guess. bug 682430 states that https imports work, but that
isn't (consistently) the case anymore either.

I'll mark bug 682430 as a dupe of this one, as this one has the more
correct explanation.

Cheers,

Jelmer

Changed in launchpad:
status: Incomplete → Triaged
importance: Undecided → High
Jelmer Vernooij (jelmer) on 2011-11-28
tags: added: code-import
Nicolas Vervelle (nvervelle) wrote :

Prevents import of code for the currently stable branch of Jmol, so no more translations can be updated in the stable versions right now

Changed in jmol:
importance: Undecided → High
Jelmer Vernooij (jelmer) wrote :

Marking this bug as invalid for jmol as it's not a bug in jmol. Please use the "This bug affects me" link for the bug if this bug affects your project.

Changed in launchpad:
status: Triaged → In Progress
assignee: nobody → Jelmer Vernooij (jelmer)
Changed in jmol:
status: New → Invalid
no longer affects: jmol
Jelmer Vernooij (jelmer) wrote :

Actually, this appears to have already landed and is working. Not sure why the QA tagger didn't pick it up.

Changed in launchpad:
status: In Progress → Fix Released
Jelmer Vernooij (jelmer) on 2012-04-02
Changed in bzr-svn:
assignee: Jelmer Vernooij (jelmer) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers