cross-format stacked branches can't be accessed

Bug #828409 reported by David Rauschenbach on 2011-08-17
4
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
Critical
[LEGACY] Canonical WebOps

Bug Description

The hyperlinks to this project don't work, and the bzr download URL does not work with 6 different versions of bzr that I've tried from Windows and Mac.

bzr: ERROR: CHKInventoryRepository('http://bazaar.launchpad.net/%2Bbranch-id/10634/.bzr/repository/')
is not compatible with
KnitPackRepository('http://bazaar.launchpad.net/~pierre-php/libmemcached/libmemcached-windows/.bzr/repository/')
different rich-root support

Hi David,

Which hyperlink are you referring to?

I will look into the bzr error.

Martin Pool (mbp) on 2011-08-18
summary: - Broken URL to libmemcached-windows
+ cross-format stacked branches can't be accessed
Martin Pool (mbp) wrote :

Well, I presume the hyperlinks he's talking about are those from <http://code.launchpad.net/~pierre-php/libmemcached/libmemcached-windows/> such as <http://bazaar.launchpad.net/~pierre-php/libmemcached/libmemcached-windows/files>.

The basic cause of the failure here is that the trunk has been upgraded and this branch hasn't been, and they're in an inconsistent state.

One solution is for ~pierre-php to click the 'upgrade' on that page.

Probably Launchpad should bulk-upgrade them; I'll see what we can do about that.

tags: added: branch-stacking codehosting
Martin Pool (mbp) wrote :

oh, and another solution is for a losa to upgrade this particular branch; I'll see if we can do that.

Martin Pool (mbp) wrote :

I think it's a bug in Launchpad that branches get in this state (or an operational issue, call it what you will).

It's not at all obvious to the affected user what they ought to do to get out of it. If they are supposed to ask the branch owner to upgrade the branch first then there is potentially several days delay while they wait and then a bit more delay if they ask a losa to do it instead. This also keeps generating user support questions.

I'm not going to work on this right now, but I think what we ought to do is find all branches in this state and upgrade them. bzr formats that can't understand 2a are quite obsolete at this point. We can possibly make a copy of them in their current semi-broken state just in case that is wanted.

Liam Young (gnuoy) wrote :

Doing a bzr check on the branch results in the following:
http://pastebin.ubuntu.com/669260/

Steve McInerney (spm) wrote :

We've tried clicking the upgrade button, as well as doing it manually.
When we go to browsse the branch we see:
"Something broke while generating the page. Please try again in a few minutes, and if the problem persists file a bug at https://bugs.launchpad.net/launchpad and quote OOPS-ID OOPS-2056CBA418" from codebrowse.

We have a tarball of the original branch saved.

Aaron Bentley (abentley) on 2011-08-18
Changed in launchpad:
status: New → Triaged
importance: Undecided → Critical
Aaron Bentley (abentley) on 2011-09-01
Changed in launchpad:
assignee: nobody → Aaron Bentley (abentley)
status: Triaged → In Progress
Aaron Bentley (abentley) wrote :

We have filed RT #47986 to upgrade all branches to 2a format. When that is complete, there will be no cross-format stacked branches, so this bug can be closed.

Changed in launchpad:
assignee: Aaron Bentley (abentley) → Canonical WebOps (canonical-losas)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers