Copy ddtp-translations uploads to new distroseries

Bug #827941 reported by Jeroen T. Vermeulen
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
Fix Released
High
Colin Watson

Bug Description

Colin asks if we could extend the custom uploads copier to copy not just debian-installer and dist-upgrader uploads from a previous distroseries into a newly-created one, but ddtp-translations tarballs as well.

Apparently the ddtp tarballs follow a different naming scheme than the other upload types:

     <NAME>_<COMPONENT>_<VERSION>.tar.gz

The <NAME> is not significant, apparently, though <COMPONENT> is. See lp.archivepublisher.ddtp_tarball.DdtpTarballUpload.

Tags: qa-ok

Related branches

Revision history for this message
Jeroen T. Vermeulen (jtv) wrote :

To illustrate, example of a ddtp translations tarball:

    translations_multiverse_20110413.tar.gz

Colin Watson (cjwatson)
Changed in launchpad:
assignee: nobody → Colin Watson (cjwatson)
status: Triaged → In Progress
Revision history for this message
Colin Watson (cjwatson) wrote :

This is probably the cause of bug 672314.

Revision history for this message
Colin Watson (cjwatson) wrote :

Oh. I thought this was easy, but DDTP tarballs are handled in a considerably weirder way than I thought; they appear to have no corresponding source upload! As a result they have no SPPH and the normal copy process won't work.

I think the right way to solve this, though, is to give them a sourceful upload; the current mechanism is just Bad And Wrong. I'll talk with Michael and see about getting this fixed.

Revision history for this message
Launchpad QA Bot (lpqabot) wrote :
tags: added: qa-needstesting
Changed in launchpad:
status: In Progress → Fix Committed
Colin Watson (cjwatson)
tags: added: qa-ok
removed: qa-needstesting
William Grant (wgrant)
Changed in launchpad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers