native syncs have no way to indicate sponsorship

Bug #827555 reported by Colin Watson on 2011-08-16
34
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Launchpad itself
Critical
Julian Edwards

Bug Description

The native sync process (using archive.copyPackage) doesn't support any way to indicate that you're sponsoring a sync for somebody else. Some examples where this is useful:

 * A sync was requested by an upstream developer, and we want to credit them as well as the person who signed it off.
 * A sync was requested by a prospective Ubuntu developer, and we want to credit them in order that they can make use of this as support for their Ubuntu developer application process (this information is used by the Developer Membership Board at the moment).

I don't know exactly how this should be represented. The person who actually did the API request gets stuffed into Signed-By, so perhaps the real requester could go in the From: header of the announcement mail or something.

Related branches

Colin Watson (cjwatson) on 2011-08-16
tags: added: derivation
Changed in launchpad:
status: New → Confirmed
Iain Lane (laney) wrote :

It's relatively important for prospective developers to have the +uploaded-packages page be as accurate as possible, so the solution should cause syncs to end up there. This information should also be retrievable using the API, so that when I get around to rewriting my script which pulls this into (Debian's) UDD we can pull out data about sponsored uploads from there too.

Aaron Bentley (abentley) on 2011-08-16
Changed in launchpad:
status: Confirmed → Triaged
importance: Undecided → Low
Julian Edwards (julian-edwards) wrote :

I have a feeling this is a dupe but I can't find the dupe, so for now it lives.

We can copy what sync-source does for sponsored uploads I guess, and just override the requesting user to an optionally provided one.

How important is this to Ubuntu?

Benjamin Drung (bdrung) wrote :

There is bug #827608 which is for unsponsored syncs.

I consider this feature critical for using native syncs for sponsored syncs. I will continue using the old way for sponsoring until this bug is fixed.

Stefano Rivera (stefanor) wrote :

And there is bug #861488 which is for showing who synced a package on the package version's page.

Changed in launchpad:
importance: Low → High
Colin Watson (cjwatson) wrote :

This also blocks moving away from 'sync-source.py -a' for mass syncs from Debian. IRC discussion here:

  http://irclogs.ubuntu.com/2011/10/03/%23launchpad-dev.html#t22:41

tags: added: escalated
Changed in launchpad:
importance: High → Critical
Francis J. Lacoste (flacoste) wrote :

Escalated by Bryce as it blocks Ubuntu from using native sync.

Iain Lane (laney) wrote :

When you fix this, can you make sure that the information is exposed through the API as follows:

  spph.package_creator = original uploader (in Debian), i.e. Changed-By
  spph.package_maintainer = maintainer (in Debian)
  spph.creator = person who the sync is on behalf of (the sponsoree or user for non-sponsored syncs)

  spph.package_signer = sponsor or blank for non-sponsored syncs

  -- or (if you want to keep package_* for Debian data) --

  spph.package_signer = person who uploaded to Debian (sponsor or DD if a non-sponsored upload), if this information is available
  spph.signer = sponsor or blank for non-sponsored syncs

Changed in launchpad:
assignee: nobody → Julian Edwards (julian-edwards)
status: Triaged → In Progress
Launchpad QA Bot (lpqabot) wrote :
tags: added: qa-needstesting
Changed in launchpad:
status: In Progress → Fix Committed
Julian Edwards (julian-edwards) wrote :

The API change to do this is ready. I'm keeping the bug open so that I can make the change in the web UI next.

tags: added: qa-ok
removed: qa-needstesting
Changed in launchpad:
status: Fix Committed → In Progress
Changed in launchpad:
status: In Progress → Fix Released
Changed in launchpad:
status: Fix Released → In Progress
Launchpad QA Bot (lpqabot) wrote :
tags: added: qa-needstesting
removed: qa-ok
Changed in launchpad:
status: In Progress → Fix Committed
tags: added: qa-ok
removed: qa-needstesting
Deryck Hodge (deryck) on 2011-12-22
Changed in launchpad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers