NotBranchError raised by upgrade_branches.py script

Bug #823485 reported by Diogo Matsubara on 2011-08-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
Critical
Aaron Bentley

Bug Description

OOPS-2046UBJ1 shows an upgrade branch job failure: NotBranchError: Not a branch: "/+branch-id/40441/".

Related branches

Robert Collins (lifeless) wrote :

This is a failure that should be reported to the user and not us - its normal for some of the hosting branches to have no valid branch content - users can do what they want, after all.

Diogo Matsubara (matsubara) wrote :

Dupe of bug 86402 then?

Robert Collins (lifeless) wrote :

No, for a few reasons;
that bug asks for better help and fixing that wouldn't necessarily imply not oopsing.
this one states that we get an OOPS which isn't one we would want to investigate immediately because its not clearly a system fault (perhaps a use for an informational oops + statistical analysis, but thats a EFUTURE project).
They are for different components - this is the job upgrader, that is the branch mirrorer.

Aaron Bentley (abentley) on 2011-08-18
Changed in launchpad:
assignee: nobody → Aaron Bentley (abentley)
status: Triaged → In Progress
Launchpad QA Bot (lpqabot) wrote :
tags: added: qa-needstesting
Changed in launchpad:
status: In Progress → Fix Committed
William Grant (wgrant) wrote :

Tested a few cases on qastaging, got https://pastebin.canonical.com/51620/. Can't see any emails, but the success case still works, so this is qa-ok.

tags: added: qa-ok
removed: qa-needstesting
William Grant (wgrant) on 2011-08-25
Changed in launchpad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers