Bug status should include 'In Review' item

Bug #74892 reported by Jamu Kakar on 2006-12-07
4
Affects Status Importance Assigned to Milestone
Launchpad itself
Low
Unassigned

Bug Description

Our development workflow with Launchpad looks something like the following:

At a project planning level we (1) File bugs for new features and known problems and (2) organize bugs into milestones.

At an individual level we (1) assign a bug to ourself from the current milestone, mark it 'In Progress', and implement a solution, (2) when the implementation is complete we post a bug comment specifying a bzr branch location and requesting a review from the Launchpad team associated with the bug and (3) we merge the branch into our production trunk when the review phase is complete and set the bug status to 'Fix Committed'.

When we deliver a milestone, the bugs we deployed to production are marked 'Fix Released'.

It'd be really nice to have an 'In Review' status that could be used to track the bugs in review. We currently use a review tag to keep track of reviews. It works well enough but only if I check it manually. An 'In Review' status would be displayed in bug listings which is what I really want.

In the future it would be nice to see Launchpad automate the review process more. Having a reviewer invite mechanism could be nice. The ability to mark oneself as having reviewed a branch and to be able to capture analyzable data about the review outcome would be awesome.

David Allouche (ddaa) wrote :

Did you notice that you can currently associate branches to bugs?

Being "in review" is a property of a branch, not of the bug. At the moment, the best way to represent it is to use the bugbranch status, or the status of the associated branch. This area is in need of polishing, but I think the way forward is for malone to make the bugbranch information more visible.

Linked this bug to the launchpad-bazaar/review-infrastructure spec.

> Did you notice that you can currently associate branches to bugs?

I'm aware of this feature but haven't used it much because our branches
are private. So, any branch-related functionality to satisfy my request
would be require private branches.

> Being "in review" is a property of a branch, not of the bug. At the
> moment, the best way to represent it is to use the bugbranch status, or
> the status of the associated branch. This area is in need of polishing,
> but I think the way forward is for malone to make the bugbranch
> information more visible.

I agree that "review" is a property of the branch. I'd like the
reviewiness of the branch to be represented on the bug listing page. My
workflow is basically to live on the (current) milestone page and
iterate over tasks I derive from it until it's completed. My ultimate
desire is to be able to go to a single page in Launchpad and answer the
question, "What should I do now?". We're not quite there yet, but I can
accomplish most of what I want now by jumping between a handful of
pages.

David Allouche (ddaa) wrote :

I think I understand your requirements:

1. private branches
2. branch review system
3. exposing the review status of bugbranch in bug listing and bug searches.

Linked this bug to the private-branches spec.

Changed in launchpad:
importance: Undecided → Wishlist
status: Unconfirmed → Confirmed
Christian Reis (kiko) wrote :

Jamu, David: please update the bug summary and description accordingly; it's currently misleading.

David Allouche (ddaa) wrote :

Setting the bug invalid because it seems to be a request for a number of independent features. Jamu, please re-open and clarify the bug if you disagree.

Changed in launchpad-bazaar:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers