page generation problem

Bug #742390 reported by Marco Lazzaroni on 2011-03-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
Critical
John A Meinel
loggerhead
Critical
John A Meinel

Related branches

William Grant (wgrant) wrote :

Traceback (most recent call last):
  Module launchpad_loggerhead.app, line 345, in wrapped_app
    app_iter = iter(app(environ, wrapped.start_response))
  Module launchpad_loggerhead.debug, line 106, in wrapped_application
    result = application(environ, response_hook)
  Module __main__, line 165, in wrapped
  Module launchpad_loggerhead.debug, line 45, in wrapped
    return app(environ, start_response)
  Module paste.translogger, line 68, in __call__
    return self.application(environ, replacement_start_response)
  Module paste.deploy.config, line 285, in __call__
    return self.app(environ, start_response)
  Module __main__, line 149, in wrapped
  Module paste.wsgilib, line 179, in catch_errors
    app_iter = application(environ, start_response)
  Module launchpad_loggerhead.session, line 53, in __call__
    return self.cookie_handler(environ, start_response)
  Module paste.auth.cookie, line 305, in __call__
    return self.application(environ, response_hook)
  Module launchpad_loggerhead.session, line 80, in _process
    return self.application(environ, response_hook)
  Module paste.httpexceptions, line 636, in __call__
    return self.application(environ, start_response)
  Module launchpad_loggerhead.app, line 230, in __call__
    return view.app(environ, start_response)
  Module loggerhead.apps.branch, line 174, in app
    return c(environ, start_response)
  Module loggerhead.controllers, line 95, in __call__
    vals.update(self.get_values(path, kwargs, headers))
  Module loggerhead.controllers.revision_ui, line 67, in get_values
    change = h.get_changes([revid])[0]
  Module loggerhead.history, line 670, in get_changes
    changes = self.get_changes_uncached(revid_list)
  Module loggerhead.history, line 706, in get_changes_uncached
    return [self._change_from_revision(rev) for rev in rev_list]
  Module loggerhead.history, line 723, in _change_from_revision
    tag.sort_natural(self._branch, tags)
AttributeError: 'module' object has no attribute 'sort_natural'

William Grant (wgrant) wrote :

The same rev works fine in Loggerhead locally.

Changed in launchpad:
importance: Undecided → Critical
status: New → Triaged
tags: added: codebrowse oops
tags: added: regression
William Grant (wgrant) wrote :

Seems to be a regression in loggerhead trunk r438, preventing it from working with older versions of bzr.

John A Meinel (jameinel) wrote :

Yeah, 'sort_natural' was introduced in bzr 2.3. I haven't been running the test suite against older versions of bzr. I wonder what the best solution is.

Certainly, if we had a way to run "eggs/bzr*/EGG-INFO/scripts/bzr selftest -s bp.loggerhead" it would catch this sort of thing. Any ideas on how we could integrate that into the system?

John A Meinel (jameinel) wrote :

Trivial fix for now:

=== modified file 'loggerhead/history.py'
--- loggerhead/history.py 2011-03-16 14:43:36 +0000
+++ loggerhead/history.py 2011-03-25 12:43:31 +0000
@@ -720,7 +720,11 @@
           # tag.sort_* functions expect (tag, data) pairs, so we generate them,
           # and then strip them
           tags = [(t, None) for t in self._branch_tags[revision.revision_id]]
- tag.sort_natural(self._branch, tags)
+ sort_func = getattr(tag, 'sort_natural', None)
+ if sort_func is None:
+ tags.sort()
+ else:
+ sort_func(self._branch, tags)
           revtags = u', '.join([t[0] for t in tags])

         entry = {

John A Meinel (jameinel) on 2011-03-25
Changed in loggerhead:
status: New → Fix Released
importance: Undecided → Critical
assignee: nobody → John A Meinel (jameinel)
Changed in launchpad:
status: Triaged → In Progress
assignee: nobody → John A Meinel (jameinel)
William Grant (wgrant) wrote :

This has been cowboyed, and the OOPSing URL works again.

Changed in launchpad:
status: In Progress → Fix Released

That was faaast!!! My compliments! Thank you very much!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers