BugTask:+index timeout - late evaluation of Person/ValidPersonCache

Bug #726370 reported by Robert Collins on 2011-02-28
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
Critical
Ian Booth

Bug Description

    5 https://bugs.launchpad.net/ubuntu/+bug/1/+index (BugTask:+index)
       OOPS-1884G2180, OOPS-1884H2231, OOPS-1884O2001, OOPS-1884O2002, OOPS-1884O2110
      4 https://bugs.launchpad.net/ubuntu/+bug/1/+index (BugTask:+index)
       OOPS-1884C856, OOPS-1884D1882, OOPS-1884F1987, OOPS-1884F879

consistently high python time.

The new appservers may help.

Am getting memcache turned off as its showing up with very large request counts and slow (24ms) individual gets that miss.

Related branches

description: updated
description: updated
Robert Collins (lifeless) wrote :

turning memcache off has helped, as have other optimisations. Still need to track the late evaluation down.

Robert Collins (lifeless) wrote :

  File "/srv/launchpad.net/codelines/lp-sourcedeps/eggs/zope.tales-3.4.0-py2.6.egg/zope/tales/expressions.py", line 211, in _eval
    return ob()
  File "/srv/launchpad.net/codelines/trunk/lib/lp/bugs/browser/bugtask.py", line 3269, in getBugTaskAndNominationViews
    conjoined_master is not None)
  File "/srv/launchpad.net/codelines/trunk/lib/lp/bugs/browser/bugtask.py", line 3207, in _getTableRowView
    view.target_link_title = self.getTargetLinkTitle(context.target)
  File "/srv/launchpad.net/codelines/trunk/lib/lp/bugs/browser/bugtask.py", line 3181, in getTargetLinkTitle
    uploader = current_release.creator
  File "/srv/launchpad.net/codelines/lp-sourcedeps/eggs/lazr.delegates-1.2.0-py2.6.egg/lazr/delegates/_delegates.py", line 130, in __get__
    return getattr(context, self.name)

Robert Collins (lifeless) wrote :

from getTargetLinkTitle:
uploader = current_release.creator
maintainer = current_release.maintainer

Robert Collins (lifeless) wrote :

Remaining case -

  File "/srv/launchpad.net/codelines/lp-sourcedeps/eggs/zope.traversing-3.8.0-py2.6.egg/zope/traversing/adapters.py", line 138, in traversePathElement
    return traversable.traverse(nm, further_path)
  File "/srv/launchpad.net/codelines/trunk/lib/lp/app/browser/tales.py", line 607, in traverse
    return getattr(self, method_name)(extra_path)
  File "/srv/launchpad.net/codelines/trunk/lib/lp/app/browser/tales.py", line 1189, in link
    return self._makeLink(view_name, rootsite, self._context.displayname)
  File "/srv/launchpad.net/codelines/trunk/lib/lp/app/browser/tales.py", line 1174, in _makeLink
    css_class = ObjectImageDisplayAPI(person).sprite_css()
  File "/srv/launchpad.net/codelines/trunk/lib/lp/app/browser/tales.py", line 722, in sprite_css
    if context.is_valid_person:
  File "/srv/launchpad.net/codelines/trunk/lib/lp/services/propertycache.py", line 116, in __get__
    value = self.populate(instance)
  File "/srv/launchpad.net/codelines/trunk/lib/lp/registry/model/person.py", line 1243, in is_valid_person
    ValidPersonCache.get(self.id)

not sure what person its rendering to trigger this yet.

Changed in launchpad:
status: Triaged → In Progress
assignee: nobody → Robert Collins (lifeless)
Robert Collins (lifeless) wrote :

  File "/srv/launchpad.net/codelines/trunk/lib/lp/bugs/browser/bug.py", line 275, in nominate
    if check_permission("launchpad.Driver", target):
  File "/srv/launchpad.net/codelines/trunk/lib/canonical/launchpad/webapp/authorization.py", line 251, in check_permission
    return zcheckPermission(permission_name, context)
  File "/srv/launchpad.net/codelines/lp-sourcedeps/eggs/zope.security-3.7.1-py2.6-linux-i686.egg/zope/security/management.py", line 143, in checkPermission

is another cause

Robert Collins (lifeless) wrote :

the cases in comment #3 are fixed.

Launchpad QA Bot (lpqabot) wrote :
Changed in launchpad:
milestone: none → 11.03
tags: added: qa-needstesting
Changed in launchpad:
status: In Progress → Fix Committed
Robert Collins (lifeless) wrote :

Note that this bug won't be fully fixed by this landing - there are multiple root causes we need to address one by one.

tags: added: qa-ok
removed: qa-needstesting
tags: removed: qa-ok
Changed in launchpad:
status: Fix Committed → Triaged
assignee: Robert Collins (lifeless) → nobody
milestone: 11.03 → none
Ian Booth (wallyworld) on 2012-10-09
Changed in launchpad:
status: Triaged → In Progress
assignee: nobody → Ian Booth (wallyworld)
Ian Booth (wallyworld) on 2012-10-10
tags: added: bugs
Ian Booth (wallyworld) on 2012-10-10
tags: added: qa-ok
William Grant (wgrant) on 2012-10-10
Changed in launchpad:
status: In Progress → Fix Committed
William Grant (wgrant) on 2012-10-11
Changed in launchpad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers