DistributionSourcePackage:+filebug Timeout trying to file bug due to FTI timeout

Bug #726175 reported by Bryce Harrington on 2011-02-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
Critical
Unassigned

Bug Description

OOPS-1884A550

https://bugs.launchpad.net/ubuntu/+source/git/+filebug/107f3cfc-4231-11e0-896d-002481e7f48a?field.title=package+git+%28not+installed%29+failed+to+install%2Fupgrade%3A+ErrorMessage%3A+subprocess+installed+post-installation+script+returned+error+exit+status+1

analysis
--------

The bug filing code is running the duplicate detector. On qastaging that query is 2.5 seconds long - it took 15 seconds on production for some reason. We might have fat indices or something minor, or we may have had a few other things:
 - gil contention reported as query time (uncommon but happens)
 - overloading DB backend
 - something else.

summary: - Timeout trying to file bug
+ DistributionSourcePackage:+filebug Timeout trying to file bug due to FTI
+ timeout
Changed in launchpad:
status: New → Triaged
importance: Undecided → Critical
tags: added: timeout
description: updated
tags: added: dba
Stuart Bishop (stub) wrote :

The full text query is just nuts - many lines of boolean operations. We can't perform this query in real time. Ideally we should stop this query getting to the ftq helper at all. We could make the ftq helper raise an exception if the query is obviously insane.

I can't reproduce this - maybe this timeout was triggered by a search bug, since fixed?

Bug.fti @@ ftq('(1&error&errormessag&exit&fail&git&instal&installupgrad&packag&post&postinstal&return&script&status&subprocess&upgrad)|(error&errormessag&exit&fail&git&instal&installupgrad&packag&post&postinstal&return&script&status&subprocess&upgrad)|(1&errormessag&exit&fail&git&instal&installupgrad&packag&post&postinstal&return&script&status&subprocess&upgrad)|(1&error&exit&fail&git&instal&installupgrad&packag&post&postinstal&return&script&status&subprocess&upgrad)|(1&error&errormessag&fail&git&instal&installupgrad&packag&post&postinstal&return&script&status&subprocess&upgrad)|(1&error&errormessag&exit&git&instal&installupgrad&packag&post&postinstal&return&script&status&subprocess&upgrad)|(1&error&errormessag&exit&fail&instal&installupgrad&packag&post&postinstal&return&script&status&subprocess&upgrad)|(1&error&errormessag&exit&fail&git&installupgrad&packag&post&postinstal&return&script&status&subprocess&upgrad)|(1&error&errormessag&exit&fail&git&instal&packag&post&postinstal&return&script&status&subprocess&upgrad)|(1&error&errormessag&exit&fail&git&instal&installupgrad&post&postinstal&return&script&status&subprocess&upgrad)|(1&error&errormessag&exit&fail&git&instal&installupgrad&packag&postinstal&return&script&status&subprocess&upgrad)|(1&error&errormessag&exit&fail&git&instal&installupgrad&packag&post&return&script&status&subprocess&upgrad)|(1&error&errormessag&exit&fail&git&instal&installupgrad&packag&post&postinstal&script&status&subprocess&upgrad)|(1&error&errormessag&exit&fail&git&instal&installupgrad&packag&post&postinstal&return&status&subprocess&upgrad)|(1&error&errormessag&exit&fail&git&instal&installupgrad&packag&post&postinstal&return&script&subprocess&upgrad)|(1&error&errormessag&exit&fail&git&instal&installupgrad&packag&post&postinstal&return&script&status&upgrad)|(1&error&errormessag&exit&fail&git&instal&installupgrad&packag&post&postinstal&return&script&status&subprocess)')

tags: removed: dba
Robert Collins (lifeless) wrote :

What I don't understand is why the query is fast on qastaging and slow on prod.

tags: added: dba
Robert Collins (lifeless) wrote :

fixed by the index repack on bug_fti

Changed in launchpad:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers