Please add sha256 checksums to the Release file

Bug #71845 reported by Michael Vogt
8
Affects Status Importance Assigned to Milestone
Launchpad itself
Fix Released
High
Celso Providelo

Bug Description

The current release file support sha-1 and md5. We would like to switch to sha256 in apt and therefore the Release file should carry the this hash as well (the Packages files already carry that checksum).

Thanks,
 Michael

Tags: lp-soyuz
Revision history for this message
James Henstridge (jamesh) wrote :

The archive publisher uses the hash utilities from the Python standard library.

Python 2.5 is the first release with an SHA256 implementation. Since we're still using 2.4, we'd need a 3rd party implementation. Do you know of such an implementation?

Revision history for this message
Michael Vogt (mvo) wrote :

The python-crypto package has sha256 support in dapper.

It is used:

import Crypto.Hash.SHA256
sha256 = Crypto.Hash.SHA256.new()

then it follows PEP 247.

Revision history for this message
Celso Providelo (cprov) wrote :

wip in my `archive-tools`

Changed in soyuz:
assignee: nobody → cprov
importance: Undecided → High
status: Unconfirmed → In Progress
Revision history for this message
Celso Providelo (cprov) wrote :

Right, the chunk below represents the shape of the Release file after adding SHA256:

{{{
...
MD5Sum:
 a5e5742a193740f17705c998206e18b6 114 main/source/Release
...
SHA1:
 6222b7e616bcc20a32ec227254ad9de8d4bd5557 114 main/source/Release
...
SHA256:
 297125e9b0f5da85552691597c9c4920aafd187e18a4e01d2ba70d8d106a6338 114 main/source/Release
...
}}}

Revision history for this message
Celso Providelo (cprov) wrote :

RF 4335

Changed in soyuz:
status: In Progress → Fix Committed
Celso Providelo (cprov)
Changed in soyuz:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers