branch page looks like it links to branches, actually links to merge proposals

Bug #711647 reported by Martin Pool on 2011-02-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
Low
William Grant

Bug Description

In the web view of revisions in a branch, eg <https://code.qastaging.launchpad.net/~bzr-pqm/bzr/bzr.dev> it would be nice to also link to the merge proposal that (probably) led to a branch landing, eg adding something like

  from _proposal_

or something like that.

Typically the mp will be in state 'merged' by the time we get here so seeing the state is not so useful. I think the main thing is to get to the mp; second most interesting maybe to see who approved it; third perhaps to see the votes (but often there are outdated votes and seeing them is noise.)

Related branches

lp:~wgrant/launchpad/more-trivialities
Colin Watson: Approve on 2015-09-10
Martin Pool (mbp) wrote :

Ian pointed out that the link all already go to the mp, not to the branch. (They're all oopsing so I didn't see that.)

It's a inconsistent with the rest of lp for a link whose text is the branch name to actually go to an mp. One way to handle that would be to just hyperlink the whole phrase 'merged branch lp:....'

Changed in launchpad:
status: Confirmed → Triaged
Martin Pool (mbp) on 2011-02-02
summary: - link from branch page to merge proposals
+ branch page looks like it links to branches, actually links to merge
+ proposals
John A Meinel (jameinel) wrote :

I agree. This could be done easily just by how it is phrased.

Launchpad QA Bot (lpqabot) wrote :
Changed in launchpad:
assignee: nobody → William Grant (wgrant)
tags: added: qa-needstesting
Changed in launchpad:
status: Triaged → Fix Committed
William Grant (wgrant) on 2015-09-11
tags: added: qa-ok
removed: qa-needstesting
Colin Watson (cjwatson) on 2015-09-14
Changed in launchpad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers