Need help for novice translators

Bug #7 reported by Mikkel Kamstrup Erlandsen on 2004-12-22
16
Affects Status Importance Assigned to Milestone
Launchpad itself
High
Данило Шеган

Bug Description

Rosetta needs help explaining how to use it. This help should cover points such as:
- What is the usage of the "%s", "%d" etc. Should they be included in translation?
- To what degree should one copy the layout of the original text? For example, sshould trailing newlines be included in translation?
- The use of _underscores as shortcuts

This might be extended to language-specific help, linking to national translation guidelines and describing the special characters and characteristics they have.

Related branches

Sivan Greenberg (sivan) wrote :

Yes, A detailed text matching each language view should be available so people would know all the special characters and characteristics of them in order to produce quality translation that attains streamlined look and feel.

Carlos Perelló Marín (carlos) wrote :

All the documentation related to Rosetta is stored at https://wiki.ubuntu.com/Rosetta

Jordi, please, could you add those questions to our current FAQ?

Thank you.

Changed in rosetta:
assignee: nobody → jordi
status: New → Accepted
Dafydd Harries (daf) wrote :

How about adding a link to the wiki on the translation page? It doesn't matter how good this documentation is if nobody knows it's there.

Alexandre Otto Strube (surak) wrote :

+1 at Dafydd.

The space and new line characters are in a discrete sqare on the left, while the '[tab]' warning is shown on each string that has a tab character.

description: updated
Jordi Mallach (jordi) on 2007-03-27
Changed in rosetta:
assignee: jordi → rosetta-admins
Joey Stanford (joey) wrote :

remove assigned to in prep for cycles

Changed in rosetta:
assignee: rosetta-admins → nobody
Matthew Paul Thomas (mpt) wrote :

I think all of the points suggested in the initial report are explained inline now, except for the underscores.

Joey Stanford (joey) wrote :

Matt, this is for the translations users guide draft you have in play. It struck me when reading it that you've accomplished much of the items on this list. Please vet your doc against these questions and when you have as much as you can, go ahead and close this bug task. Thanks..Joey

Changed in launchpad-documentation:
assignee: nobody → matthew.revell
importance: Undecided → Medium
milestone: none → 1.2.6
status: New → Confirmed
Adi Roiban (adiroiban) wrote :

For the Romanian translation team we have created a translation guided used by all other Romanian tranlsation projects (GNOME, Mozilla, OpenOffice).
It is a wiki page and it would be great if the users with less than 100 poins in translations would be displayed a top page notice to read this guide, similar to the top page notice from edge.

Right now, at least for people translation in Romanian, I have to send them an email pointing to this wiki page.
The link is also put on the page of the Romanian Localzation Team.

It would be great if wiki page could be created on Launchpad, initialy in English and later it can be translated using Rosetta.

Joey Stanford (joey) wrote :

Please complete this work in 1.99 as best you can

Changed in rosetta:
assignee: nobody → jtv
importance: Medium → High
milestone: none → 1.99
Changed in launchpad-documentation:
milestone: 1.2.6 → 1.99

The new translations section of the Launchpad user guide (https://help.launchpad.net/Translations) does give a brief introduction for translators. However, most of that section is aimed at project owners.

So, during the next Launchpad cycle I'll work with translators and members of Ubuntu loco teams to update the user guide section to ensure it offers comprehensive and straightforward help to translators themselves, as well as suggesting changes to the UI etc.

Changed in launchpad-documentation:
milestone: 1.99 → none
status: Confirmed → In Progress
Changed in launchpad-documentation:
milestone: none → 2.1.8
Joey Stanford (joey) on 2008-08-01
Changed in rosetta:
milestone: 1.99 → 2.1.8

Matt, please let us know when the documentation is there, so we can add the link to translation pages.

Changed in rosetta:
status: Confirmed → Incomplete
Changed in rosetta:
milestone: 2.1.8 → 2.1.9

Following discussion on the ubuntu-translators list (https://lists.ubuntu.com/archives/ubuntu-translators/2008-August/001635.html) I've gathered further suggestions on what the page could include:

"-> The obvious step: how to get an account, links to another article
talking about, etc.

-> Information about Rosetta: not advanced but not short information.
What Rosetta does? What gettext means? It's free? Can I use it? And
important: the type of permissions. Next point...

-> Start translating: localize the project url in Launchpad, and check
if the translation is being done by someone. As I mentioned before, we
need to explain about permissions and check if the project allow us to
provide "free translation" or we need something (join in a group, for
example). Obviously, we need to say also that the user need to select
the languages where he has knowledge. We remember him also the strings
that need review are important.

-> Ways to stay in touch with the rest: mailing lists, IRC, etc.

I think explanations about the HTML entities like & and XML tags found in translation strings are pretty important.

I think it would be useful also to have some sort of explanation about
all the UI elements that you a translator can use like the drop-down
list with all the viewing options (translated items, items with new
suggestions...), what the "Located in..." string means and so on...

It is important to talk about the format operator (%) and how you're
supposed to change its position inside a string; the text "formatting"
tags like <b></b>, <i></i>, <span size="large"></span> saying that the
text *inside* a tag must not be translated; the "accelerators"...

For newcomers it will be useful to remember them about already existing
translation groups and (how) to keep in touch with them.

Probably talking about gettext is too advanced for new translators, as
Launchpad tries to hide gettext magic from translators, but maybe there
should be room for an "Advanced" section in this document or a document
for advanced users where you can talk about:
 - gettext
 - po and mo file formats
 - how to upload a file, what it means "User upload" or "Published
upload" and what happen when you select one or the other...

Upstream/downstrean problematics. It is imperative to make new translators aware that the packages the are interested in, perhaps are mainly translated somewhere else and give them some hint about how to find where.

What role do teams play in ensuring consistent and professional translations?"

I've written a new page on the Launchpad help wiki that takes someone through the first steps of translating with Launchpad:

https://help.launchpad.net/Translations/StartingToTranslate

Changed in launchpad-documentation:
status: In Progress → Fix Released
Adi Roiban (adiroiban) wrote :

This is the link to the wiki page used by all Romanian translation teams.
http://www.i18n.ro/Ghidul_traducatorului_de_software

It explains the translation rules, what string should not be translated, common errors...

Maybe we can include a link for each language that already have such translation guides.

For example on this page: https://translations.edge.launchpad.net/ubuntu/hardy/+source/hwtest/+pots/hwtest/ro/+translate we should see this text:

--------

Template "TEMPLATENAME" in PROJECTNAME package "PACKAGENAME"
Translating into LANGUAGE, using <a href="#link to guide"> this set of rules</a>.

-------

It is great to have a general wiki page on help.launchpad.net but there are also some specific notes for each Language.

Jordi Mallach (jordi) wrote :

Including personalised information for each team with links to glossaries, conventions or style guides is requested in bug #3.
I should probably draft a specification, if it still does not exist, because this is an old and often requested feature.

Adi Roiban (adiroiban) wrote :

The language-glossary-link blueprint https://blueprints.edge.launchpad.net/rosetta/+spec/language-glossary-links is dealing this problem.

Even thout the title is about a glossary , the blueprint content also talks about a wiki page with translation rules, font configuration.. etc

Changed in rosetta:
assignee: jtv → nobody
status: Incomplete → Confirmed
Changed in rosetta:
assignee: nobody → danilo
Changed in rosetta:
milestone: 2.1.9 → 2.1.10
Changed in rosetta:
milestone: 2.1.10 → 2.1.11
Changed in rosetta:
milestone: 2.1.11 → 2.1.12
Changed in rosetta:
status: Confirmed → In Progress

Fixed in RF 7340.

Changed in rosetta:
status: In Progress → Fix Committed
Changed in rosetta:
status: Fix Committed → Fix Released
Changed in launchpad-documentation:
status: Fix Released → Fix Committed
Changed in rosetta:
status: Fix Released → Fix Committed

Hi Clarence, I'm changing the statuses on this bug back to Fix Released because the fix has been made and is available for use.

If you disagree that the bug is fixed, please say so in the comments here.

Changed in launchpad-documentation:
status: Fix Committed → Fix Released
Changed in rosetta:
status: Fix Committed → Fix Released
avguser (onetigerone) wrote :

8 out of 9 times firefox 7 hangs or freezes all together. Ever since I got this upgrade it's been nothing but problems. It hangs,freezes to the point where it feels like the computer is crashing but, when I look into the taskmgr, it just shows the hanging apps. firefox.exe second line firefox.exe and the same for the third line. I click end process for the first line and they all go. I have a pic of what I am seeing in the error console but, have no idea how to read java script. But, I will post the pic anyways. I hope it helps.

tags: added: iso-testing
tags: removed: iso-testing

Ubuntu already has documentation for translators: https://wiki.ubuntu.com/Translations

Changed in ubuntu:
status: New → Invalid
William Grant (wgrant) on 2012-07-16
no longer affects: ubuntu

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-eoan' to 'verification-done-eoan'. If the problem still exists, change the tag 'verification-needed-eoan' to 'verification-failed-eoan'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-eoan
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers