AssertionError editing a question

Bug #697294 reported by Diogo Matsubara on 2011-01-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
Critical
j.c.sackett

Bug Description

As seen on OOPS-1826B1089 an AssertionError: Open question shouldn't have an answerer. was raised when the user tried to edit the question.

Related branches

Curtis Hovey (sinzui) on 2011-01-04
Changed in launchpad:
status: New → Triaged
importance: Undecided → High
tags: added: questions
Curtis Hovey (sinzui) wrote :

The user was trying to set the package to cups to classify the solution picked by the user. This is a legitimate case. The form does not permit the user to change status...that is a separate form with sane controls on it.

This question is open, but I also see a star on a question indicating it was solved. I see from the question history that the asker reopened the question. There are *no* answers after the reopening. Only the asker is providing more information.

Module lp.answers.browser.question, line 747, in change_action
self.updateContextFromData(data)
Module lp.app.browser.launchpadform, line 427, in updateContextFromData
context, context_before_modification, field_names))
...
Module lp.answers.model.questionreopening, line 67, in create_questionreopening
"Open question shouldn't have an answerer.")
AssertionError: Open question shouldn't have an answerer.

The code took an unexpected path after updating the question. create_questionreopening is subscribed to objectEventNotify. The method did work when the question was reopened. It will work again once a user provides an answer. Since the status has not changed, I expect create_questionreopening to return early if there is no status change.

maybe
    if old_question.status == question.status
        return

Changed in launchpad:
importance: High → Critical
j.c.sackett (jcsackett) on 2011-01-25
Changed in launchpad:
status: Triaged → In Progress
assignee: nobody → j.c.sackett (jcsackett)
Launchpad QA Bot (lpqabot) wrote :
Changed in launchpad:
milestone: none → 11.02
tags: added: qa-needstesting
Changed in launchpad:
status: In Progress → Fix Committed
Curtis Hovey (sinzui) on 2011-02-05
tags: added: qa-ok
removed: qa-needstesting
William Grant (wgrant) on 2011-02-07
Changed in launchpad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers