No ability to manually trigger a build 'like the daily build system'

Bug #687623 reported by Robert Collins on 2010-12-09
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Launchpad itself
Low
Ian Booth

Bug Description

As it says on the box. See bug 682923 for conversation around this - but its about the dialog UI, this is about the functionality.

Related branches

Aaron Bentley (abentley) wrote :

I think this could be an attractive nuisance. If daily builds are enabled, running a manual build with the same parameters causes pain: Bug #684515

Jonathan Lange (jml) wrote :

Could we change the system so that a manually triggered build counts as the daily build for that day?

Wanting a build now with the same parameters as the daily doesn't seem fundamentally wrong. It seems that the problem is that the daily build will go ahead anyway.

On Thu, Dec 23, 2010 at 5:50 AM, Jonathan Lange <email address hidden> wrote:
> Could we change the system so that a manually triggered build counts as
> the daily build for that day?

If no new commits have been done, that would make sense to me.

> Wanting a build now with the same parameters as the daily doesn't seem
> fundamentally wrong. It seems that the problem is that the daily build
> will go ahead anyway.

We could detect same-details and do a no-change-rebuild transform to
the package (as documented in the Ubuntu developer docs for rebuilding
failed packages).

Tim Penhey (thumper) on 2011-01-07
tags: added: recipe
Changed in launchpad:
status: New → Triaged
importance: Undecided → Low
Ian Booth (wallyworld) wrote :

As discussed with Tim, recipes which are scheduled to be built daily will get a "Build now" action to manually initiate the daily build. The action will only be available if the recipe is stale and the user has upload permissions to the recipe's daily build archive. The action performs the same operation as the request_daily_builds job run by the cron script.

Changed in launchpad:
status: Triaged → In Progress
Launchpad QA Bot (lpqabot) wrote :
Changed in launchpad:
assignee: nobody → Ian Booth (wallyworld)
milestone: none → 11.03
tags: added: qa-needstesting
Changed in launchpad:
status: In Progress → Fix Committed
William Grant (wgrant) on 2011-02-24
tags: added: qa-ok
removed: qa-needstesting
William Grant (wgrant) on 2011-02-25
Changed in launchpad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers