LocationError in DistroSeries:+queue

Bug #685401 reported by Robert Collins on 2010-12-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
High
William Grant

Bug Description

Wgrant thinks that this is caused by overzealous expiry in translations affecting the page.

Alternatively the page could not show gc'd files, but apparently thats crazy talk.

OOPS-1799A559 and similar

https://launchpad.net/ubuntu/lucid/+queue?queue_state=3&queue_text=&start=126240

 /srv/launchpad.net/production/launchpad-rev-12004/lib/lp/soyuz/browser/../templates/distroseries-queue.pt
    - Line 281, Column 11
    - Expression: <PathExpr standard:u'custom/libraryfilealias/content/filesize/fmt:bytes'>
 ...
 LocationError: (None, 'filesize')

Related branches

description: updated
description: updated
William Grant (wgrant) wrote :

It's in the Done queue, so I suspect that Translations ran the query in bug #262767. This is reasonably illegal, since we now have partial bits of uploads missing. But probably not a problem until we start handling custom uploads less insanely.

We should probably just de-link expired files from listings, since they should only ever happen in Done.

affects: rosetta → soyuz
Julian Edwards (julian-edwards) wrote :

It's an easy fix in the template.

Changed in soyuz:
status: New → Triaged
tags: added: queue-page trivial ui
William Grant (wgrant) on 2010-12-20
Changed in launchpad:
assignee: nobody → William Grant (wgrant)
status: Triaged → In Progress
tags: added: bugjam2010
tags: added: qa-needstesting
Changed in launchpad:
status: In Progress → Fix Committed
William Grant (wgrant) on 2010-12-21
tags: added: qa-ok
removed: qa-needstesting
William Grant (wgrant) on 2010-12-23
Changed in launchpad:
status: Fix Committed → Fix Released
Curtis Hovey (sinzui) on 2011-01-11
Changed in launchpad:
milestone: none → 11.01
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers