librarian apache log parser failing to parse bogus line in access log

Bug #676489 reported by Diogo Matsubara on 2010-11-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
High
Gary Poster

Bug Description

As see on OOPS-1781C2045 a ValueError: too many values to unpack was raised while parsing the access log

Related branches

tags: added: librarian oops
affects: launchpad-dev-moin-theme → launchpad-foundations
Gary Poster (gary) on 2010-11-17
Changed in launchpad-foundations:
status: New → Triaged
importance: Undecided → Low
importance: Low → High
Gary Poster (gary) wrote :

I investigated and found the original URL on devpad. The problem is that the path has a space in it, so our split gets four elements instead of three. I have a quick branch.

Changed in launchpad-foundations:
assignee: nobody → Gary Poster (gary)
Changed in launchpad-foundations:
milestone: none → 10.12
tags: added: qa-needstesting
Changed in launchpad-foundations:
status: Triaged → Fix Committed
tags: added: qa-ok
removed: qa-needstesting
Robert Collins (lifeless) wrote :

We've done a nodowntime deploy, but I don't know if thats enough to release this.

Gary Poster (gary) wrote :

Thanks, yes.

Changed in launchpad-foundations:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers