Some valid failures in process-upload should not OOPS

Bug #673590 reported by Ursula Junque on 2010-11-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
Low
Julian Edwards

Bug Description

As seen in OOPS-1774FTPMASTER1:
  EarlyReturnUploadError: An error occurred that prevented further processing.

This is a valid failure but should not oops.

Related branches

Changed in soyuz:
status: New → Triaged
importance: Undecided → Low
tags: added: soyuz-upload
Julian Edwards (julian-edwards) wrote :

Some of the other OOPSes like OOPS-1782PPA118 are caused by the log level being an "error" in do_accept when it catches exceptions and logs them.

This needs to change so that if it's a QueueInconsistentStateError it logs at info as these are routine errors.

Julian Edwards (julian-edwards) wrote :

Meant to say - any LaunchpadCronScript auto-files OOPSes when logging at "warn" or above.

Changed in soyuz:
status: Triaged → In Progress
assignee: nobody → Julian Edwards (julian-edwards)
milestone: none → 10.12
Changed in soyuz:
status: In Progress → Fix Committed
tags: added: qa-ok
removed: qa-needstesting
Julian Edwards (julian-edwards) wrote :

See also OOPS-1785PPA71

The fix for this one is another logger change.

Changed in soyuz:
status: Fix Committed → In Progress
Robert Collins (lifeless) wrote :

Not deployed to the uploader machines yet, sorry for the noise.

Changed in soyuz:
status: In Progress → Fix Released
status: Fix Released → Fix Committed
Curtis Hovey (sinzui) on 2010-12-08
Changed in soyuz:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers