review type field for merge proposal not always enabled

Bug #671665 reported by Ian Booth on 2010-11-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
Medium
Ian Booth

Bug Description

Now that a default reviewer is chosen when creating a merge proposal, the reviewer field is initially blank. The review type field is now also disabled until a reviewer has been chosen. Selecting a reviewer using the popup chooser doesn't enable the review type field. Workaround is to type and remove a character in the reviewer field.

Related branches

Ian Booth (wallyworld) wrote :

I think that the root of the problem is that when the Person/Team selection popup is closed and the selected value inserted into the reviewer field, the reviewer field is not given focus. Hence there is no possibility to tab out of the field to trigger the onchange event. IMHO, typing the value directly or using a popup should result in the same end result - a populated field which has focus, thereby allowing subsequent event triggers to be properly processed.

Ian Booth (wallyworld) wrote :

Important is medium - workaround exists but confusing ui and usability issues without the fix.

Changed in launchpad-code:
importance: Undecided → Medium
Ian Booth (wallyworld) on 2010-11-08
Changed in launchpad-code:
status: Triaged → In Progress
Changed in launchpad-code:
milestone: none → 10.12
tags: added: qa-needstesting
Changed in launchpad-code:
status: In Progress → Fix Committed
Ian Booth (wallyworld) on 2010-12-01
tags: added: qa-ok
removed: qa-needstesting
Curtis Hovey (sinzui) on 2010-12-08
Changed in launchpad-code:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers