PPAs should not publish non-main components

Bug #662088 reported by William Grant on 2010-10-17
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Launchpad itself
High
Julian Edwards

Bug Description

Nowadays PPAs only publish packages in the 'main' component -- an attempt to create a publication in any other component will be redirected. Yet they still publish indices for restricted, universe and multiverse. This should be prevented in the same manner as the partner archive only publishes the partner component.

Related branches

William Grant (wgrant) on 2010-10-17
Changed in soyuz:
assignee: nobody → William Grant (wgrant)
William Grant (wgrant) wrote :

It looks like the sources.list generator asks for all components for PPAs. That may need fixing too.

Jelmer Vernooij (jelmer) on 2010-11-05
Changed in soyuz:
status: New → Confirmed
Changed in soyuz:
status: Confirmed → Triaged
importance: Undecided → Low
tags: added: ppa soyuz-publisher
Julian Edwards (julian-edwards) wrote :

Boosting priority since this is affecting publisher performance hard.

Changed in soyuz:
assignee: William Grant (wgrant) → Julian Edwards (julian-edwards)
importance: Low → High
Changed in soyuz:
status: Triaged → In Progress
Changed in soyuz:
milestone: none → 10.12
tags: added: qa-needstesting
Changed in soyuz:
status: In Progress → Fix Committed
tags: added: qa-ok
removed: qa-needstesting
Curtis Hovey (sinzui) on 2010-12-08
Changed in soyuz:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers