Team admin can't contact prospective member who hides e-mail addresses

Bug #66105 reported by Matthew Paul Thomas
34
Affects Status Importance Assigned to Milestone
Launchpad itself
Medium
Barry Warsaw

Bug Description

If someone in Launchpad has chosen to keep their e-mail addresses hidden from everybody, and then applies for membership in a team, a team administrator has no way of contacting them to discuss their membership.

Launchpad should either provide forms for letting an administrator and a prospective member e-mail each other (without necessarily knowing each other's addresses), or the addresses of a prospective team member should be disclosed to the team's administrators.

<mhb> hello launchpad masters ... I need to contact a LP user because he wants to join the team I'm managing but I can't seem to find the email address

description: updated
Revision history for this message
Matthew East (mdke) wrote :

For all the teams I'm involved in, this isn't required: the model is that the onus is on the potential new member to contact the relevant administrator/mailing list in order to apply for membership.

In circumstances where people apply for membership and do not read the introductory text under the team page in order to contact the right people, the membership application is ignored/rejected.

Revision history for this message
Matthew Paul Thomas (mpt) wrote :

That's a good workaround, but it's still bong that the process Launchpad advertises isn't appropriate by itself. :-)

Changed in launchpad:
status: Unconfirmed → Confirmed
Revision history for this message
Tony Yarusso (tonyyarusso) wrote :

Agreed that there are methods available, but it would be very nice to have some handy buttons - like the "message member" in eBay for instance, where addresses remain hidden, but you can still make contact. Additionally, it would be nice to have an option to e-mail all team members. For instance, the Minnesota LoCo team just got started, and has applied for a mailing list, so once the mailing list is put in place by admins it would be very helpful to be able to send a message to that effect to all Launchpad team members, as prior to that there would be no list to send to.

So, both individual and team contact buttons with undisclosed addresses would be nice.

Revision history for this message
Matthew Revell (matthew.revell) wrote : Something for moderated teams

My suggestion is that we add a "Request info" button to the proposed member's membership status page. This could sit alongside the "Accept" and "Decline" buttons we already have.

My use case is the Launchpad Beta Testers team. We require that Launchpad beta testers agree to a couple of things before they join the team. The only way to communicate with users who have hidden their email address is to reject their application. We're not really rejecting their application but simply requesting more information.

I think implementing this would help moderated teams without bringing into question why people hide their email addresses: is it because they don't want any contact or is it because they don't want other LP users knowing their email address?

A like the idea of a "contact this user" button, for general use, but in the mean time a "Request info" button on the membership status page would rock.

Christian Reis (kiko)
Changed in launchpad:
importance: Undecided → Medium
Revision history for this message
LaserJock (laserjock) wrote :

What I've done in the past was Accept then Deactivate them with a message that they need to email me before they are reactivated. Not very elegant, and in fact I've never had a single one email me either. I think a "Request info" should be in the Administrator toolbox.

Revision history for this message
Tony Yarusso (tonyyarusso) wrote :

Whatever the fix will be, it shouldn't be limited to only at the time of approving the membership application. There are potentially situations where you'd want to be able to contact team members later on as well I'd imagine, both individually and as a whole team.

Revision history for this message
Christian Reis (kiko) wrote :

I see a few implementation options for this bug:

  - Providing a mechanism for team admins to contact applicants via a webform in the approval page.
  - Providing a webform to post a message to any user, linked from the person's page.
  - Offering a generic email alias for a Launchpad user (<email address hidden>) as SourceForge does.

The first is specific to this bug, the latter two are more generic. The last is the most controversial of the options.

Emailing all team members is proposed in bug 44545 (I could swear there was another bug, but anyway..)

Revision history for this message
Mark Shuttleworth (sabdfl) wrote :

I'm -1 on a generic email alias, because for most people it feels like an added risk of spam and yet another email address for them to keep track of. I have never used my SF email but feel a little negative about the idea that it even exists.

In this specific case, if the page where the admin declines their membership request also had an option to send a message, then there would be no need. This is especially true if the page could be used without actually changing the status, just to send a message to the user, by the team admin. Of course, only team admins for teams that the user had requested to join would have this facility. I think as a general rule being able to be contacted in response to something one initiated is reasonable even if you are hiding your email address.

As a final option, a general "contact this person" web form would work, though we may need to go down the captcha route if we find spam becomes a problem.

Mark

Curtis Hovey (sinzui)
Changed in launchpad:
assignee: nobody → sinzui-is
Revision history for this message
Christian Reis (kiko) wrote :

Cool, let's get this started. If we are doing a change to +member, then perhaps we can add an additional button that says something like "Ask for information" that would go along with the existing buttons. However, we need to be careful that the message sent allows the recipient to reply to the right people -- otherwise it's just a one-way communication channel.

Revision history for this message
Tony Yarusso (tonyyarusso) wrote :

Perhaps the field for Reply-To could be derived from the login cookie, which would ensure that a) it would allow a properly routed reply every time, b) spam would be limited, since messaging would only be possible for people who have Launchpad accounts at least, and possibly just the team admins of teams they've applied to / are current members of. I'd think there would be some similar code to start with for bug comments like this, etc.?

Revision history for this message
Tony Yarusso (tonyyarusso) wrote :

I thought of another thing that would be helpful on a somewhat related note:
Right now a number of LoCo teams set their team to moderated (including Minnesota), not because we actually restrict membership, but solely to make sure we notice new members and are prompted to take the time to fire off a welcome e-mail. It would be nice if teams could set a welcome message to be sent when new members joined or were approved, much like the mailing lists currently do. While this does not fix this bug, it would cut down on the number of occasions when the fix would be needed, so I thought it fit here.

Revision history for this message
Curtis Hovey (sinzui) wrote :

This is a late start, but I hope to get this in the 1.1.10 release.

Changed in launchpad:
status: Confirmed → In Progress
Curtis Hovey (sinzui)
Changed in launchpad:
milestone: 1.1.10 → 1.1.11
Curtis Hovey (sinzui)
Changed in launchpad:
milestone: 1.1.11 → 1.1.12
status: In Progress → Confirmed
Changed in launchpad:
milestone: 1.1.12 → none
assignee: sinzui-is → nobody
Revision history for this message
Curtis Hovey (sinzui) wrote :

We should make an effort to deliver this for the 2.1.10 cycle.

Changed in launchpad-foundations:
milestone: none → 2.1.10
status: Confirmed → Triaged
Curtis Hovey (sinzui)
Changed in launchpad-foundations:
assignee: nobody → barry
Revision history for this message
Barry Warsaw (barry) wrote :
Barry Warsaw (barry)
Changed in launchpad-registry:
milestone: 2.1.10 → 2.1.11
status: Triaged → In Progress
Barry Warsaw (barry)
Changed in launchpad-registry:
status: In Progress → Fix Committed
Barry Warsaw (barry)
Changed in launchpad-registry:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints