demystifying +addseries and +addbranch

Bug #6604 reported by David Allouche on 2006-01-10
8
Affects Status Importance Assigned to Milestone
Launchpad itself
Low
Unassigned

Bug Description

James reported that some users are confused by the +addseries page, and use it when they mean +addbranch. David also noticed at least one branch url set to a foreign RCS. Something should be done to clear up the confusion.

David Allouche (ddaa) wrote :

A sort term solution could be adding some explanatory text on +addseries and +addbranch explaining clearly what they are for, and linking to the other page.

That would be a bit difficult for me because I still do not understand the use cases for product series.

Also, I think that, maybe, RCS import details should become a optional decoration of branch, because it seems that the distinction between "a bazaar branch" and "a rcs import to bazaar" is not obvious. That would also help the confusion with RCS imports from branches (ha! you see, confusing!) that are not used for making releases.

Dafydd Harries (daf) on 2006-02-09
Changed in launchpad:
assignee: nobody → mpt
David Allouche (ddaa) wrote :

That bug report is a bit unfocused. Also significant work has been done to make it clearer what +addbranch is for, and productseries are now consisently referred to as "series" or "release series" instead of branches. Making fixreleased as the issue has been addressed to my satisfaction.

Changed in launchpad:
assignee: mpt → nobody
status: Unconfirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers