Comment 0 for bug 659870

Gavin Panella (allenap) wrote :

Using the search box on https://bugs.launchpad.net/ and attempting to
locate a particular bug, in this case bug 658227, does not work if a
version string ("4.8") is included in the search terms.

The description of that bug is currently set to:

  upgrade process does not upgrade underlying BDB format from 4.7 to
  4.8 (so slapd aborts with "Program version 4.8 doesn't match
  environment version 4.7" error message)

To reproduce:

- In the search form on bugs.launchpad.net, leave the radio button
  next to "All projects" selected and enter "Program version 4.8
  doesn't match environment" into the search box. No bugs will be
  found.

- Remove the "4.8" from the search terms (leaving "Program version
  doesn't match environment") and the bug will be found (among
  others).