Deleting recipe leaves SourcePackageReleases with no traceability

Bug #645620 reported by William Grant on 2010-09-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
High
Aaron Bentley

Bug Description

devel r11598 makes SourcePackageRecipe deletion nullify references on its SourcePackageReleases. This leaves us with a SourcePackageRelease for which we cannot determine an uploader. We really need to know who to blame.

Related branches

On Thu, 23 Sep 2010 10:23:45 you wrote:
> Public bug reported:
>
> devel r11598 makes SourcePackageRecipe deletion nullify references on
> its SourcePackageReleases. This leaves us with a SourcePackageRelease
> for which we cannot determine an uploader. We really need to know who to
> blame.
>
> ** Affects: launchpad-code
> Importance: Undecided
> Status: New

  importance high
  status triaged
  tag recipe

Changed in launchpad-code:
importance: Undecided → High
status: New → Triaged
Tim Penhey (thumper) wrote :

What other ways can we have the traceability without keeping the recipe around? Where could we tag the build with useful information?

Changed in launchpad-code:
status: Triaged → Incomplete
William Grant (wgrant) wrote :

You can't tag the build, since that's what you're inappropriately deleting. If you want to delete all sorts of important stuff, you will need to add some new field to store this information.

Also, this bug is not Incomplete. All the information about the problem is here, we just need to work out a solution.

Tim Penhey (thumper) on 2010-11-05
Changed in launchpad-code:
status: Incomplete → Triaged
Aaron Bentley (abentley) wrote :

Our current idea is to make the recipe column on SourcePackageRecipeBuild nullable and change recipe deletion to null that field instead of deleting the build record. Since source package recipe build URLs include their recipe, this will make them unreachable from the web UI and web service, but they'll be in the database if you really need them. Sound good?

Tim Penhey (thumper) on 2010-11-15
Changed in launchpad-code:
status: Triaged → In Progress
assignee: nobody → Aaron Bentley (abentley)
Changed in launchpad-code:
milestone: none → 10.12
tags: added: qa-needstesting
Changed in launchpad-code:
status: In Progress → Fix Committed
Aaron Bentley (abentley) on 2010-11-22
tags: added: qa-untestable
removed: qa-needstesting
Curtis Hovey (sinzui) on 2010-12-08
Changed in launchpad-code:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers