test_runAll_mails_oopses fails sometimes

Bug #644984 reported by Michael Nelson
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
Critical
Māris Fogels

Bug Description

This test is erroring sometimes on ec2 recently... it hadn't failed on buildbot until:

https://lpbuildbot.canonical.com/builders/lucid_db_lp/builds/238

(which only had a merge from stable).

I can't reproduce it locally (nor can others who were asked), but StevenK says his hudson builder is failing consistently:

https://hudson.wedontsleep.org/job/db-devel/44/testReport/lp.services.job.tests.test_runner/TestJobRunner/test_runAll_mails_oopses/

From the hudson failure, it looks like there is sometimes an extra oops (the test is checking for OOPS-1725T6 but gets OOPS-1725T7. But note that this is different to the buildbot (and ec2) error, which seems to be a 500 because an oops *isn't* raised.

summary: - test_runAll_mails_oopses has spurious failures
+ test_runAll_mails_oopses fails sometimes
description: updated
description: updated
description: updated
Revision history for this message
Robert Collins (lifeless) wrote : Re: [Bug 644984] Re: test_runAll_mails_oopses fails sometimes

This should have been fixed today when leonard landed his branch with
my fix included.

Revision history for this message
Jonathan Lange (jml) wrote :

Michael has landed a change to db-devel that disables the test. I have a similar change queued in PQM for devel.

Revision history for this message
Michael Nelson (michael.nelson) wrote :

I'm just attaching the results of the test run in case it helps. One thing that seems strange, both jml and I had 2 unrelated Windmill errors along with the oops test that failed. Once the oops test was disabled, these windmill tests passed also.

Revision history for this message
Robert Collins (lifeless) wrote :

On Thu, Sep 23, 2010 at 8:47 PM, Michael Nelson
<email address hidden> wrote:
> I'm just attaching the results of the test run in case it helps. One
> thing that seems strange, both jml and I had 2 unrelated Windmill errors
> along with the oops test that failed. Once the oops test was disabled,
> these windmill tests passed also.

The windmill stuff is noise, the test was fixed on devel, please renable it.

-Rob

Revision history for this message
Launchpad QA Bot (lpqabot) wrote : Bug fixed by a commit
Changed in launchpad-foundations:
assignee: nobody → Michael Nelson (michael.nelson)
milestone: none → 10.10
tags: added: qa-needstesting
Changed in launchpad-foundations:
status: New → Fix Committed
Māris Fogels (mars)
Changed in launchpad-foundations:
importance: Undecided → Critical
assignee: Michael Nelson (michael.nelson) → Māris Fogels (mars)
Revision history for this message
Māris Fogels (mars) wrote :

Our prod_lp builder is now dead because of this error: https://lpbuildbot.canonical.com/builders/prod_lp/builds/119

I am bumping the priority on fixing this up to Critical until I can get the problem resolved.

Revision history for this message
Māris Fogels (mars) wrote :

We now have fixes in prod_lp and devel. I have not see the error again. If it resurfaces then please reopen this bug.

Gary Poster (gary)
Changed in launchpad-foundations:
status: Fix Committed → Fix Released
Gary Poster (gary)
tags: added: qa-untestable
removed: qa-needstesting
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers