Disabling the account thru Wiki causes more harm than good. That option should be nuked.

Bug #6283 reported by ChristopherCmolik on 2005-12-29
32
Affects Status Importance Assigned to Milestone
Launchpad itself
Medium
Joey Stanford

Bug Description

The user disabled his account thru the wiki and couldn't log into UserPreferences anymore. The option to "permanently disable the account" should be removed as it causes more harm than good.

I deleted my old account (ChristopherCmolik) thru the wiki by checking "permanently disable the account." I went on to create another launchpad account because i changed email addresses. The account registred successfully, and I can login to launchpad. If i try to login thru the wiki, however, it says "wrong password." I've tried password resets to no avail. If i login thru launchpad, it works and i can edit pages. however, i can't get to userpreferences

James Henstridge (jamesh) wrote :

What are the names of your new and old Launchpad accounts?

You shouldn't have needed to delete your account to change email address: you could have just registered the new email address to your existing account.

As for having clicked "permanently disable account" in moin, I believe that requires admin intervention to undo -- there is no web UI for reenabling an account that you permanently disabled.

I permanently deleted my old launchpad account, ChristopherCmolik
(<email address hidden>.) My new account is <email address hidden>
(wikiname Christophercmolik)

On Thursday 29 December 2005 09:49, James Henstridge wrote:
> Public bug report changed:
> https://launchpad.net/malone/bugs/6283
>
> Comment:
> What are the names of your new and old Launchpad accounts?
>
> You shouldn't have needed to delete your account to change email
> address: you could have just registered the new email address to your
> existing account.
>
> As for having clicked "permanently disable account" in moin, I believe
> that requires admin intervention to undo -- there is no web UI for
> reenabling an account that you permanently disabled.

So your old account was "chrispgskn" and the new one is "christophercmolik" by the look of it.

It would be a good idea to merge the old account into the new one using the following form:
  https://launchpad.net/people/+requestmerge

As I said in the previous email, you don't need to create a new Launchpad account if you get a new email address. You can manage the email addresses associated with your account at:
  https://launchpad.net/people/christophercmolik/+editemails

You should be able to log into the wiki with one of the emails associated with your account as the login name, and your launchpad password as the password then.

Diogo Matsubara (matsubara) wrote :

Does the suggestion by James Henstridge solved the problem? Are you able to login again?

Changed in launchpad:
status: Unconfirmed → Needs Info
description: updated
Changed in launchpad:
status: Needs Info → Confirmed
Luca Falavigna (dktrkranz) wrote :

Same problem here. I am still trying to reactivate my wiki account, but I think only an administrator could do that.

Matthew Nuzum (newz) wrote :

Instructions for resolving this problem can be found here: https://launchpad.canonical.com/FixingDisabledWikiUsers

I'm happy to handle incidents like this in the future if needed. In case I'm not available, any of the sysadmins can resolve it.

Matthew Nuzum (newz) wrote :

Sorry I didn't make the previous post clear. :-] Joel, you should be able to use the wiki now like normal. When asked to login, just use your launchpad e-mail address and password.

The link I posted is for canonical sys-admins and launchpad developers who may need to resolve this issue in the future.

Diogo Matsubara (matsubara) wrote :
Changed in launchpad:
assignee: nobody → spiv
Anjan (t-anjan) wrote :

Sorry for the trouble to sys-admins, but I've also "disabled my account forever" through the Wiki User Preferences page by mistake. Is it possible for a sys-admin to re-activate my account for me?

On 14/03/07, Anjan <email address hidden> wrote:
> Sorry for the trouble to sys-admins, but I've also "disabled my account
> forever" through the Wiki User Preferences page by mistake. Is it
> possible for a sys-admin to re-activate my account for me?
>
> --
> Disabling the account thru Wiki causes more harm than good. That option should be nuked.
> https://launchpad.net/bugs/6283
>

I thought this option would have been nuked by now?

--
Joel Shea <email address hidden>
GPG Key ID: 0xA992856D

Matthew Paul Thomas (mpt) wrote :

Anjan, please make your request at <https://answers.launchpad.net/launchpad> so it doesn't get lost.

Anjan (t-anjan) wrote :

I just opened a support ticket. Thanks.

Joey Stanford (joey) wrote :

This is properly done with a config option. user_checkbox_remove = ['disabled',]

Tested on my Spads approved moin setup. Submitted RT #30264 for this to be added to the Launchpad help wiki.

Changed in launchpad:
assignee: spiv → rinchen
status: Confirmed → In Progress
Changed in launchpad-documentation:
milestone: none → 1.2.3
Diogo Matsubara (matsubara) wrote :

Joey, this should be also applied to help.u.c and wiki.u.c.

Thanks

Joey Stanford (joey) wrote :

Ok. I don't have authority to do that so I'll ask IS to get approval from Distro

Joey Stanford (joey) wrote :

mpt, in what area does Launchpad itself need to be fixed? I see you added the "also affects" but didn't include a reason.

Matthew Paul Thomas (mpt) wrote :

This bug was reported about wiki.ubuntu.com, the login mechanics of which have previously been handled by developers of Launchpad itself. When this bug was reported, help.launchpad.net didn't even exist; that the same bug also exists on that wiki is (as you've said) something that needs fixing separately, and therefore should be tracked independently.

Joey Stanford (joey) wrote :

ah ok. I've previously updated my RT request to cover both wiki.ubuntu.com and help.launchpad.net

Joey Stanford (joey) wrote :

Unfortunately I have to untarget this. The correct way to do this is via a wikiconfig option. However, that option does not exist in the very old copy of moin we're running. We are planning to upgrade to a newer version, probably 1.6.something, at which time this option can be applied. I've added it to my notes for the upgrade and will apply it then. While the upgrade will happen soon-ish, there is not yet a date assigned to it.

Changed in launchpad-documentation:
milestone: 1.2.3 → none
Séb Buch (seb-buch) wrote :

Same problem here: I just can not login thru the wiki ("wrong password" error) with my launchpad account.
I have merged two launchpad accounts (I may have disabled one "wiki" account) and since then, I just can not log in.

Diogo Matsubara (matsubara) wrote :

Hi Sébastien,

you wiki account has been re-enabled. Please try to log in again.
Next time, it's better if you file a new question <https://answers.launchpad.net/launchpad>. It helps us keep track of the resolution of your specific problem

Thanks, Matsubara

Diogo Matsubara (matsubara) wrote :

Hi Sébastien,

your wiki account has been re-enabled. Please try to log in again.
Next time, it's better if you file a new question <https://answers.launchpad.net/launchpad>. It helps us keep track of the resolution of your specific problem

Thanks, Matsubara

Changed in launchpad:
assignee: nobody → rinchen
status: New → Confirmed
Joey Stanford (joey) on 2008-04-23
Changed in launchpad:
importance: Undecided → Medium
status: Confirmed → In Progress
Joey Stanford (joey) wrote :

All of the updated wikis will have this option enabled. We plan to roll them out in a few weeks.

Joey Stanford (joey) wrote :

The launchpad help wiki has been updated to the new code and this option removed.

Changed in launchpad-documentation:
milestone: none → 1.2.6
status: In Progress → Fix Released
Joey Stanford (joey) wrote :

This was fixed with the Ubuntu wiki upgrade about two months ago or so.

Changed in launchpad-registry:
status: In Progress → Fix Released
milestone: none → 2.1.10
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers