Help link on project series page is broken.

Bug #616847 reported by Henning Eggers on 2010-08-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Launchpad itself
High
j.c.sackett

Bug Description

On a project series' home page is a link for a help pop-up labeled "How do I verify a download" that leads to a 404.
See here: https://code.edge.launchpad.net/me-tv/1.2/1.2.3

A user had reported OOPS-1681G4 about it.

Related branches

tags: added: oops
Curtis Hovey (sinzui) wrote :

This is an impossible url. The link does not work because the user got to page from the code.launchpad.net domain that should not exist. The link works on launchpad.net, where the page exists.

affects: launchpad-registry → launchpad-code
Tim Penhey (thumper) wrote :

Curtis, that link is unfortunately valid. Not sure how they got there though. The milestone pages should set the layer I guess. I'm currently dealing with similar issues for code pages.

affects: launchpad-code → launchpad-registry
Curtis Hovey (sinzui) on 2010-08-13
Changed in launchpad-registry:
status: New → Triaged
importance: Undecided → High
tags: added: trivial
Changed in launchpad-registry:
milestone: none → 10.09
Curtis Hovey (sinzui) wrote :

We either need to clone the content across help domains or craft a nasty url as was done in the advanced search page for bugs:
    a tal:attributes="href string:${bugs_rooturl}/+help/tag-search.html"
                      target="help">Tag search help</a>

j.c.sackett (jcsackett) wrote :

This bug is caused by a hand crafted url in product-branch-summary.pt. It should use a menu.

Changed in launchpad-registry:
assignee: nobody → j.c.sackett (jcsackett)
affects: launchpad-registry → launchpad-code
Changed in launchpad-code:
assignee: j.c.sackett (jcsackett) → nobody
milestone: 10.09 → none
milestone: none → 10.09
assignee: nobody → j.c.sackett (jcsackett)
status: Triaged → In Progress
Ursula Junque (ursinha) on 2010-08-17
Changed in launchpad-code:
status: In Progress → Fix Committed
j.c.sackett (jcsackett) on 2010-08-17
tags: added: qa-ok
removed: qa-needstesting
Curtis Hovey (sinzui) on 2010-09-09
Changed in launchpad-code:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers