Creating recipe for build-from-branch OOPses

Bug #589454 reported by Barry Warsaw
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Launchpad itself
High
Paul Hummer

Bug Description

I tried to create a recipe to build a branch from source:

https://code.edge.launchpad.net/~barry/ubuntu/lucid/vm-builder/firstboot/+new-recipe

but I got an OOPS:

OOPS-1615EA2203

Related branches

Curtis Hovey (sinzui)
affects: launchpad → launchpad-code
Revision history for this message
Aaron Bentley (abentley) wrote :

This looks like a bug in the code that checks for duplicate recipe names.

tags: added: recipe ui
Changed in launchpad-code:
assignee: nobody → Paul Hummer (rockstar)
Aaron Bentley (abentley)
Changed in launchpad-code:
importance: Undecided → High
Paul Hummer (rockstar)
Changed in launchpad-code:
status: New → In Progress
Revision history for this message
Paul Hummer (rockstar) wrote :

This appears to be caused by the user not entering a name for the recipe, so while the duplicate recipe name code made it appear earlier, it was a bug before that recipe name code was there.

Revision history for this message
Paul Hummer (rockstar) wrote :

Fixed in devel 10972

Changed in launchpad-code:
status: In Progress → Fix Committed
milestone: none → 10.06
Revision history for this message
Ursula Junque (ursinha) wrote : Bug fixed by a commit
tags: added: qa-needstesting
Aaron Bentley (abentley)
tags: added: qa-ok
removed: qa-needstesting
Curtis Hovey (sinzui)
Changed in launchpad-code:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers